New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

#714 FIX #717

Merged
merged 5 commits into from Sep 2, 2017

Conversation

Projects
None yet
4 participants
@TikhomirovSergey
Member

TikhomirovSergey commented Sep 1, 2017

Change list

  • Update to Selenium 3.5.3
  • phantomJSdriver and htmlunit-drive were excluded
  • eclipse compiler was updated to 4.6.1
  • also AppiumElementLocator was improved

Types of changes

  • No changes in production code.
  • Bugfix (non-breaking change which fixes an issue)
  • New feature (non-breaking change which adds functionality)
  • Breaking change (fix or feature that would cause existing functionality to not work as expected)

Details

Dependencies of the html unit driver
https://mvnrepository.com/artifact/org.seleniumhq.selenium/htmlunit-driver/2.27

Dependencies of the phantom js driver
https://mvnrepository.com/artifact/com.codeborne/phantomjsdriver/1.4.3

Also something weird was foaund in AppiumElementLocator. I wonder why we couldn't find it before.

TikhomirovSergey added some commits Aug 28, 2017

#714 FIX
- Update to Selenium 3.5.3
- phantomJSdriver and htmlunit-drive were excluded
- eclipse compiler was updated to 4.6.1
@@ -21,8 +21,6 @@
import static io.appium.java_client.pagefactory.ThrowableUtil.isStaleElementReferenceException;
import com.google.common.base.Function;

This comment has been minimized.

@mykola-mokhnach

mykola-mokhnach Sep 2, 2017

Contributor

I also see this import in several other sources - are they all expected?

@mykola-mokhnach

mykola-mokhnach Sep 2, 2017

Contributor

I also see this import in several other sources - are they all expected?

This comment has been minimized.

@TikhomirovSergey

TikhomirovSergey Sep 2, 2017

Member

@mykola-mokhnach No
Except the AppiumFunction class. I improved sourses at my last commit

@TikhomirovSergey

TikhomirovSergey Sep 2, 2017

Member

@mykola-mokhnach No
Except the AppiumFunction class. I improved sourses at my last commit

@@ -54,14 +54,18 @@ compileJava {
]
}
ext.seleniumVersion = '[3.5.2,3.5.2]'
ext.seleniumVersion = '[3.5.3,3.5.3]'

This comment has been minimized.

@mykola-mokhnach

mykola-mokhnach Sep 2, 2017

Contributor

what is the point to set a range, which includes only one item? Isn't it simply equal to '3.5.3'?

@mykola-mokhnach

mykola-mokhnach Sep 2, 2017

Contributor

what is the point to set a range, which includes only one item? Isn't it simply equal to '3.5.3'?

This comment has been minimized.

@TikhomirovSergey

TikhomirovSergey Sep 2, 2017

Member

@mykola-mokhnach The purpose is to make a valid pom.xml file. The version like 3.5+ is malformed for maven.

@TikhomirovSergey

TikhomirovSergey Sep 2, 2017

Member

@mykola-mokhnach The purpose is to make a valid pom.xml file. The version like 3.5+ is malformed for maven.

@mykola-mokhnach

This comment has been minimized.

Show comment
Hide comment
@mykola-mokhnach

mykola-mokhnach Sep 2, 2017

Contributor

I was also thinking about enforcing the version of guava library, since our module cannot work if it is older than 20

Contributor

mykola-mokhnach commented Sep 2, 2017

I was also thinking about enforcing the version of guava library, since our module cannot work if it is older than 20

@SrinivasanTarget

This comment has been minimized.

Show comment
Hide comment
@SrinivasanTarget

SrinivasanTarget Sep 2, 2017

Member

@TikhomirovSergey As @mykola-mokhnach suggested i think we should force com.google.guava:guava:23.0 dependency.

Member

SrinivasanTarget commented Sep 2, 2017

@TikhomirovSergey As @mykola-mokhnach suggested i think we should force com.google.guava:guava:23.0 dependency.

#714 FIX
- test improvement
@TikhomirovSergey

This comment has been minimized.

Show comment
Hide comment
@TikhomirovSergey

TikhomirovSergey Sep 2, 2017

Member

@SrinivasanTarget I will try it with the com.google.guava:guava:23.0 dependency.

Member

TikhomirovSergey commented Sep 2, 2017

@SrinivasanTarget I will try it with the com.google.guava:guava:23.0 dependency.

@codacy-bot

This comment has been minimized.

Show comment
Hide comment
@codacy-bot

codacy-bot Sep 2, 2017

Codacy Here is an overview of what got changed by this pull request:

Complexity decreasing per file
==============================
+ src/test/java/io/appium/java_client/ios/IOSElementTest.java  -3
         

See the complete overview on Codacy

codacy-bot commented Sep 2, 2017

Codacy Here is an overview of what got changed by this pull request:

Complexity decreasing per file
==============================
+ src/test/java/io/appium/java_client/ios/IOSElementTest.java  -3
         

See the complete overview on Codacy

@TikhomirovSergey

This comment has been minimized.

Show comment
Hide comment
@TikhomirovSergey

TikhomirovSergey Sep 2, 2017

Member

@SrinivasanTarget I think it is not necessary to force the com.google.guava:guava:23.0 because Selenium already depends on this version.

https://mvnrepository.com/artifact/org.seleniumhq.selenium/selenium-remote-driver/3.5.3

Member

TikhomirovSergey commented Sep 2, 2017

@SrinivasanTarget I think it is not necessary to force the com.google.guava:guava:23.0 because Selenium already depends on this version.

https://mvnrepository.com/artifact/org.seleniumhq.selenium/selenium-remote-driver/3.5.3

@TikhomirovSergey TikhomirovSergey merged commit 4e47690 into appium:master Sep 2, 2017

2 checks passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
licence/cla Contributor License Agreement is signed.
Details
@SrinivasanTarget

This comment has been minimized.

Show comment
Hide comment
@SrinivasanTarget

SrinivasanTarget Sep 2, 2017

Member

I think it is not necessary to force the com.google.guava:guava:23.0 because Selenium already depends on this version.

Ok

Member

SrinivasanTarget commented Sep 2, 2017

I think it is not necessary to force the com.google.guava:guava:23.0 because Selenium already depends on this version.

Ok

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment