Settingslogic 2.0.7 is not comaptible with ruby 1.8.7 due to its dependency on ruby-debug19.
gem 'settingslogic', '~>2.0.6'
in my Gemfile. Then bundle failed
# bundle install
Gem::InstallError: linecache19 requires Ruby version >= 1.9.2.
An error occured while installing linecache19 (0.5.12), and Bundler cannot continue.
Make sure that `gem install linecache19 -v '0.5.12'` succeeds before bundling.
I think settingslogic should not depend on ruby-debug19 when using ruby 1.8.7.
If there is any reason (other than ruby-debug19) settingslogic have become incompatible with ruby 1.8.7, than it's version should be bumped to 2.1.0 and keep branch 2.0.x compatible with 1.8.7.
Another issue is that ruby-debug19 is a runtime dependency when it should be a development / test dependency.
I'm working on a quick fix for this, unless Ben has time.
Potential fix submitted in pull request here:
This should be fixed in 2.0.8
@dush @wpeterson I think it's safe to close this issue now. :)