Skip to content
Compare
Choose a tag to compare
  • Fix PHP 8.2 deprecated string interpolation syntax (Thanks @Ayesh!)
  • Fix PHP 8.1 deprecation warnings in Hoa readline code
  • Ensure that pre-built phars exclude dependencies with known vulnerabilities
  • Set the update checker timeout to 1 second
Compare
Choose a tag to compare
  • Fix missing import in userland readline implementation (Thanks @zonuexe!)
Compare
Choose a tag to compare
  • Enable output paging for stdout and return value dumping.
  • Prevent wrapping with the default less paging options. If you want the old style back, add 'pager' => 'less -R -S -F -X' to your PsySH config! (Thanks @ooglek!)
  • Fix grapheme polyfill issue when using pre-built phars.
  • Remove deprecated hoa/console support.
  • Include a userland readline implementation (based on the old hoa/console!).
  • Deprecate "compat" builds. Everyone on supported versions of PHP should be able to use the default phar build now!

👆👆 Note that if you've previously used a "compat" build, you don't need to anymore!

Compare
Choose a tag to compare
  • Fix tab completion when input starts with whitespace (Thanks @orange-alien!)
  • Fix deprecation notice when running psy\info() in PHP 8.x (Thanks @virtual-designer!)
  • Fix type error at exit when using enums in PHP 8.1.
  • Stop logging warnings when @ error suppression operator is present.
  • Update to latest box and php-scoper versions.
  • Disable Box parallel processing in CI.
  • Fresh pre-built Phar builds that actually work 😳
Compare
Choose a tag to compare
  • Fix nullable types in the history command (Thanks @tgooren!)
  • Add allow-plugins configuration for Composer 2.2 (Thanks @villfa!)
  • Improve PHPUnit assertions (Thanks @peter279k!)
  • Support variadic placeholder params in PHP 8.1.
Compare
Choose a tag to compare

Kinda big:

  • Drop support for PHP 5.x and HHVM.
  • Add support for Symfony 6.
  • Bump minimum versions of Symfony and PHP-Parser to merely "ancient" and not "prehistoric".

All the small things:

  • Drop function call and constant fetch input validation (PHP can now recover from these at runtime, so we'll just handle the error!)
  • Fix bracketed paste support dectection issue for some readline implementations (MinGWEditLine?).
  • Add supportsBracketedPaste to the Readline interface.
  • All the param types and return types.
  • Add @dev and lowest-version dependency testing to CI.

In case you missed it above, PsySH v0.11.0 drops support for PHP 5.x and HHVM.

Please. It's almost 2022. If you're not using PHP 8 already, make that your New Year's resolution.

Compare
Choose a tag to compare

This release is largely to fix broken pre-built Phars. PsySH v0.11.x will remove support for PHP 5.x and HHVM, but I didn't want to leave y'all with broken binaries on the last version supporting PHP 5.x :)

  • Fix pre-built Phars in older versions of PHP.
  • Improve doc command output with inherited docs.

Note: Skipping PsySH v0.10.10 due to release script issues.

Compare
Choose a tag to compare
  • Various code style fixes (Thanks @GrahamCampbell!)
  • Fix checking pass-by-reference with array fetch.
  • Distinctly style integer and float number types (Thanks @1ma!)
  • Test against PHP 8.1, minor fixes so tests pass.
  • Update HHVM CI environment, which unfortunately required us to drop testing for all but one HHVM version.

Note that PsySH v0.11.x will remove support for PHP 5.x and HHVM. That means this is quite likely the last release for either of those.

Compare
Choose a tag to compare
  • Add support for accessing private properties and consts from parent classes via sudo.
  • Make psy\info() more resilient when extending Psy\Shell rather than using it directly.
  • Set $__file and $__dir magic variables after calling show $path.
  • Clean up path configuration, make it testable.
  • Add more smoketests to the phar build.

Note that v0.10.8 officially removes support for PHP 5.5 in the pre-built phars. They've been broken in PHP 5.5 since v0.10.0 a year ago, due to an incompatibility in the library we use to isolate code, so this is mostly about messaging that incompatibility.

Users who need to use PsySH under PHP 5.5 can continue to install via Composer, or download pre-built phars from v0.9.x.