Skip to content
This repository has been archived by the owner. It is now read-only.

Extensions have connectivity issues with Strict Site Isolation #12612

Closed
Jacalz opened this Issue Jan 11, 2018 · 22 comments

Comments

Projects
None yet
8 participants
@Jacalz
Copy link
Collaborator

Jacalz commented Jan 11, 2018

New description:

Seems like both Lastpass and Bitwarden are experiencing these issues! probably more also!!!

Old description

Lastpass breaks when you enable "strict site isolation". The extension gives an error that it was unable to connect to the servers after you enable that option.

Steps to Reproduce

  1. Install lastpass from about:preferences#extensions
  2. Log in to lastpass with an account
  3. Go to about:preferences#security and enable "strict site isolation"

Actual result:
Lastpass enters offline mode because it can´t connect to the servers.
image

Expected result:
Should work like a dream :)

Reproduces how often:

All the time

Brave Version

about:brave info:

Brave: 0.19.131
rev: da2f347
Muon: 4.5.36
libchromiumcontent: 63.0.3239.132
V8: 6.3.292.49
Node.js: 7.9.0
Update Channel: Release
OS Platform: Microsoft Windows
OS Release: 10.0.16299
OS Architecture: x64

Reproducible on current live release:

YES

@Jacalz

This comment has been minimized.

Copy link
Collaborator Author

Jacalz commented Jan 11, 2018

+1 from a user on Reddit

@Jacalz

This comment has been minimized.

Copy link
Collaborator Author

Jacalz commented Jan 11, 2018

You might need to update lastpass to the latest version to fix this, version 4.5.0 was released 3 days ago while you are on 4.3.0.5...

@Jacalz Jacalz changed the title Lastpass has no internet connection with "strict site isolation" Some password manager extensions have no internet connection with "strict site isolation" on Jan 11, 2018

@Jacalz

This comment has been minimized.

Copy link
Collaborator Author

Jacalz commented Jan 12, 2018

The same thing can not be reproduced in chrome with “strict site isolation” so this must be in Brave only

@josefadamcik

This comment has been minimized.

Copy link

josefadamcik commented Jan 14, 2018

+1
I observe the same issue with LastPass in Brave on Linux. Also, Pocket doesn't work in site isolation either.

Brave: 0.19.131
rev: da2f347
Muon: 4.5.36
libchromiumcontent: 63.0.3239.132
V8: 6.3.292.49
Node.js: 7.9.0
Update Channel: Release
OS Platform: Linux
OS Release: 4.13.0-21-generic
OS Architecture: x64

@Jacalz

This comment has been minimized.

Copy link
Collaborator Author

Jacalz commented Jan 14, 2018

Might be an issue with all extensions 😅 cc @diracdeltas on this

@bsclifton bsclifton added this to the Triage Backlog milestone Jan 15, 2018

@bsclifton

This comment has been minimized.

Copy link
Member

bsclifton commented Jan 15, 2018

Strict Site Isolation does appear to affect multiple extensions

@eljuno

This comment has been minimized.

Copy link
Contributor

eljuno commented Jan 17, 2018

@eljuno

This comment has been minimized.

Copy link
Contributor

eljuno commented Jan 19, 2018

@Jacalz

This comment has been minimized.

Copy link
Collaborator Author

Jacalz commented Jan 19, 2018

This really needs to be fixed, needing to disable strict site isolation because if the use of a password manager is a security issue in itself 😔

@eljuno

This comment has been minimized.

Copy link
Contributor

eljuno commented Jan 23, 2018

@Jacalz Jacalz changed the title Some password manager extensions have no internet connection with "strict site isolation" on Extensions have not internet objection with strict site isolation Jan 23, 2018

@eljuno

This comment has been minimized.

Copy link
Contributor

eljuno commented Feb 2, 2018

@natv

This comment has been minimized.

Copy link

natv commented Apr 17, 2018

+1
Just installed Brave today so this is on a completely fresh setup (with 'strict site isolation' on, was the first thing I turned on.

@Jacalz

This comment has been minimized.

Copy link
Collaborator Author

Jacalz commented Apr 17, 2018

@Twitchykid

This comment has been minimized.

Copy link

Twitchykid commented Apr 23, 2018

+1

Toggled it and a bunch of other settings and took me a little while to isolate the issue.

@LaurenWags

This comment has been minimized.

Copy link

LaurenWags commented Jun 11, 2018

@eljuno

This comment has been minimized.

@bsclifton bsclifton changed the title Extensions have not internet objection with strict site isolation Extensions have connectivity issues with Strict Site Isolation Jul 2, 2018

@bsclifton

This comment has been minimized.

Copy link
Member

bsclifton commented Jul 22, 2018

+1 from @stefanperson via #14794

Enabling "Strict Site Isolation" breaks Yubikey U2F 2FA.

Steps to Reproduce

  1. Enable Strict Site Isolation
  2. Login to ex) google mail
  3. Enter username
  4. Enter password
  5. Enter 2FA. Prompts user with error. See attached pics.

screen shot 2018-07-20 at 1 31 29 pm
screen shot 2018-07-20 at 1 30 54 pm

@bsclifton

This comment has been minimized.

Copy link
Member

bsclifton commented Sep 18, 2018

Issues with strict site isolation are fixed with brave-core 😄

You can download the developer channel release here:
https://brave.com/download-dev

@stefanperson

This comment has been minimized.

Copy link

stefanperson commented Sep 18, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.