FAQ

Alexandre @buro edited this page Aug 21, 2015 · 27 revisions
Clone this wiki locally

— This is cheating, your website must be accessed from any platform, any system, any browser.

We are all about graceful degradation for many years now, we just want to give you a tool on your arsenal where you:

1 — You, the developer. Can decide what's outdated for the specific project you are about to publish. This is not a rigid rule for any website and depends on the project and it's target. If you can do a fully functional website across on all browsers: great, if not you can inform the users that they won't see what they should and that they must upgrade it. If they ignore it they will remember it later. The most important thing is that you decide when to warn them that they should update the browser. If it makes sense to the functionality you need, warn them and give them the possibility to update.

2 — You, the user. The website points them to the most recent version of the most commons browsers. The website is not for the developer, that's the plugin, the website it's the most simple interface we could came up with.

— What about all the other Browsers that are not listed?

This tool doesn't try to cover all the available options of browsers, it's just a simplified website for the less techsavvy people: The clients that say "How Do I Do That" when you ask them to clean the cache of the browser or to update the browser. More options mean less focus so we decided to include all the browsers with >= 1% usage.

— And what about the users that have windows XP and can't use IE11 or Edge?

They can use chrome, or FF, or Opera. Again our task is not to solve the browser community problems, even the browser teams skip this, again this is tool for: the developer to inform when you need a certain version, the user to upgrade the browser easily.

— Does outdated-browser works below IE11 ?

Yes, this plugin works in IE6+ versions (we had no chance to test it on <IE6)

— Can we target IE11?

At the moment the property 'transform-style: preserve-3d' is not very reliable (there are reports of false positives in some OS/Browsers), and there is no other property that we can differentiate from Edge. So as soon there is a update on Edge of a property not supported by IE11 ( filter, object-fit, etc) we will update the plugin

— The plugin is not working in older browsers!

Make sure there aren't any javascript errors in your code before calling outdatedbrowser plugin, specially in older browsers (sometimes those errors only show up in older browsers while in modern browsers you don't have any error message — always test your site). Try this: call outdatedbrowser.min.js and the function outdatedbrowser({.....}), before any other scripts you have!

— Why can’t we have more options? Why the JavaScript and CSS looks outdated?

Because they are outdated! We are well aware that the JavaScript and CSS could be optimized, and it would be cool to have more options, but remember this is NOT for modern browsers! The HTML, CSS and JavaScript must work properly in very old browsers (IE6, IE7, etc), so there is no point to use the latest recommendations or fancy options if it fails on those browsers. PS: a google search if a property or method works in an older browser is not enough! Tests must be made on those browsers, we had really bad experiences with that, so do please be aware of that ;).

— Went to the website outdatedbrowser.com and I get a message saying that my browser is outdated, when it's not!

No! You do not get any message in the website! The website does not check if you have an outdated browser, it's the plugin that you embed on your current project that does that. Read carefully what it says in the website, specially the project link: http://outdatedbrowser.com/project

— What IE browsers do you detect?

Actually we detect CSS properties, and correlate with IE support. The plugin can detect IE8+ browsers, bellow that we don't make any distinction, after all they are all outdated.

— What about all the users that can't update the browser because of IT restrictions?

We don't force the users to update, this tool is just to make them aware that the website that they are about to see is a huge compromise when compared to the full experience. We did this because our websites are not simple and most of the times some of the core visual interfaces doesn't work on older browsers. The problem is that many people don't know this and just want it working on their browser. Use the Outdated Browser to reduce this list.

— What about the mobile version? WTF is this Keep Calm stuff?

It's humor ;) This tool was thought to the desktop browser community because the mobile browsers vary too much. Mobile version is now accessible for the ones who want to check the website. As the mobile updates are different, and usually the mobile versions of the websites are already a striped down version website from all the fancy artillery that we like to use on desktop, the outdatedbrowser for mobile is not that relevant for the problem that this tool tries to solve. If the community keeps on requesting this update, we will consider to develop it.

— Translations

The translation is finally available for anyone who is willing to participate:
Plugin — use the branch develop
Website — use the branch feature/languages-website
We'll keep you posted as soon as we have languages available!

— Minified files

We recommend the use of the outdatedBrowser.min.css and outdatedBrowser.min.js files for Production, but we have at your disposal the unminify versions: outdatedBrowser.css and outdatedBrowser.js

— WordPress

Deblyn Prado did a plugin of Outdated Browser specially for WordPress. You can get it and make any report or suggestion here: wp-outdated-browser

— Ruby Gem

Luisa Lima did a gem for including outdated-browser in the Rails asset pipeline. Get it and make any report or suggestion here: outdatedbrowser_rails


Enjoy and feel free to give us your opinion on how we can do this better, or what we are doing wrong on Github.