Skip to content
Permalink
Browse files
1.18.1150
[ci skip]
  • Loading branch information
Travis CI committed Sep 17, 2019
1 parent 78b043f commit e15a04d02e80302a459f3b65664eff46b17442e1
@@ -225,13 +225,13 @@ console.log (ccxt.exchanges) // print all available exchanges

All-in-one browser bundle (dependencies included), served from a CDN of your choice:

* jsDelivr: https://cdn.jsdelivr.net/npm/ccxt@1.18.1149/dist/ccxt.browser.js
* unpkg: https://unpkg.com/ccxt@1.18.1149/dist/ccxt.browser.js
* jsDelivr: https://cdn.jsdelivr.net/npm/ccxt@1.18.1150/dist/ccxt.browser.js
* unpkg: https://unpkg.com/ccxt@1.18.1150/dist/ccxt.browser.js

CDNs are not updated in real-time and may have delays. Defaulting to the most recent version without specifying the version number is not recommended. Please, keep in mind that we are not responsible for the correct operation of those CDN servers.

```HTML
<script type="text/javascript" src="https://cdn.jsdelivr.net/npm/ccxt@1.18.1149/dist/ccxt.browser.js"></script>
<script type="text/javascript" src="https://cdn.jsdelivr.net/npm/ccxt@1.18.1150/dist/ccxt.browser.js"></script>
```

Creates a global `ccxt` object:
@@ -35,7 +35,7 @@ const Exchange = require ('./js/base/Exchange')
//-----------------------------------------------------------------------------
// this is updated by vss.js when building

const version = '1.18.1149'
const version = '1.18.1150'

Exchange.ccxtVersion = version

@@ -43,7 +43,7 @@ const Exchange = require ('./js/base/Exchange')
//-----------------------------------------------------------------------------
// this is updated by vss.js when building

const version = '1.18.1149'
const version = '1.18.1150'

Exchange.ccxtVersion = version

@@ -13993,7 +13993,7 @@ module.exports = class bitfinex2 extends bitfinex {
symbol = marketId;
}
}
orderId = trade[3];
orderId = trade[3].toString ();
takerOrMaker = (trade[8] === 1) ? 'maker' : 'taker';
const feeCost = trade[9];
const feeCurrency = this.safeCurrencyCode (trade[10]);
@@ -369,14 +369,14 @@ JavaScript (for use with the ``<script>`` tag):

All-in-one browser bundle (dependencies included), served from a CDN of your choice:

- jsDelivr: https://cdn.jsdelivr.net/npm/ccxt@1.18.1149/dist/ccxt.browser.js
- unpkg: https://unpkg.com/ccxt@1.18.1149/dist/ccxt.browser.js
- jsDelivr: https://cdn.jsdelivr.net/npm/ccxt@1.18.1150/dist/ccxt.browser.js
- unpkg: https://unpkg.com/ccxt@1.18.1150/dist/ccxt.browser.js

CDNs are not updated in real-time and may have delays. Defaulting to the most recent version without specifying the version number is not recommended. Please, keep in mind that we are not responsible for the correct operation of those CDN servers.

.. code:: html

<script type="text/javascript" src="https://cdn.jsdelivr.net/npm/ccxt@1.18.1149/dist/ccxt.browser.js"></script>
<script type="text/javascript" src="https://cdn.jsdelivr.net/npm/ccxt@1.18.1150/dist/ccxt.browser.js"></script>

Creates a global ``ccxt`` object:

@@ -62,14 +62,14 @@ JavaScript (for use with the ``<script>`` tag):

All-in-one browser bundle (dependencies included), served from a CDN of your choice:

- jsDelivr: https://cdn.jsdelivr.net/npm/ccxt@1.18.1149/dist/ccxt.browser.js
- unpkg: https://unpkg.com/ccxt@1.18.1149/dist/ccxt.browser.js
- jsDelivr: https://cdn.jsdelivr.net/npm/ccxt@1.18.1150/dist/ccxt.browser.js
- unpkg: https://unpkg.com/ccxt@1.18.1150/dist/ccxt.browser.js

You can obtain a live-updated version of the bundle by removing the version number from the URL (the ``@a.b.c`` thing) — however, we do not recommend to do that, as it may break your app eventually. Also, please keep in mind that we are not responsible for the correct operation of those CDN servers.

.. code:: html

<script type="text/javascript" src="https://cdn.jsdelivr.net/npm/ccxt@1.18.1149/dist/ccxt.browser.js"></script>
<script type="text/javascript" src="https://cdn.jsdelivr.net/npm/ccxt@1.18.1150/dist/ccxt.browser.js"></script>

Creates a global ``ccxt`` object:

Some generated files are not rendered by default. Learn more.

@@ -1,6 +1,6 @@
{
"name": "ccxt",
"version": "1.18.1149",
"version": "1.18.1150",
"description": "A JavaScript / Python / PHP cryptocurrency trading library with support for 130+ exchanges",
"main": "./ccxt.js",
"unpkg": "dist/ccxt.browser.js",
@@ -34,7 +34,7 @@
use kornrunner\Solidity;
use Elliptic\EC;

$version = '1.18.1149';
$version = '1.18.1150';

// rounding mode
const TRUNCATE = 0;
@@ -53,7 +53,7 @@

class Exchange {

const VERSION = '1.18.1149';
const VERSION = '1.18.1150';

public static $eth_units = array (
'wei' => '1',
@@ -459,7 +459,7 @@ public function parse_trade ($trade, $market = null) {
$symbol = $marketId;
}
}
$orderId = $trade[3];
$orderId = (string) $trade[3];
$takerOrMaker = ($trade[8] === 1) ? 'maker' : 'taker';
$feeCost = $trade[9];
$feeCurrency = $this->safe_currency_code($trade[10]);
@@ -369,14 +369,14 @@ JavaScript (for use with the ``<script>`` tag):

All-in-one browser bundle (dependencies included), served from a CDN of your choice:

- jsDelivr: https://cdn.jsdelivr.net/npm/ccxt@1.18.1149/dist/ccxt.browser.js
- unpkg: https://unpkg.com/ccxt@1.18.1149/dist/ccxt.browser.js
- jsDelivr: https://cdn.jsdelivr.net/npm/ccxt@1.18.1150/dist/ccxt.browser.js
- unpkg: https://unpkg.com/ccxt@1.18.1150/dist/ccxt.browser.js

CDNs are not updated in real-time and may have delays. Defaulting to the most recent version without specifying the version number is not recommended. Please, keep in mind that we are not responsible for the correct operation of those CDN servers.

.. code:: html

<script type="text/javascript" src="https://cdn.jsdelivr.net/npm/ccxt@1.18.1149/dist/ccxt.browser.js"></script>
<script type="text/javascript" src="https://cdn.jsdelivr.net/npm/ccxt@1.18.1150/dist/ccxt.browser.js"></script>

Creates a global ``ccxt`` object:

@@ -22,7 +22,7 @@

# ----------------------------------------------------------------------------

__version__ = '1.18.1149'
__version__ = '1.18.1150'

# ----------------------------------------------------------------------------

@@ -4,7 +4,7 @@

# -----------------------------------------------------------------------------

__version__ = '1.18.1149'
__version__ = '1.18.1150'

# -----------------------------------------------------------------------------

@@ -2,7 +2,7 @@

# -----------------------------------------------------------------------------

__version__ = '1.18.1149'
__version__ = '1.18.1150'

# -----------------------------------------------------------------------------

@@ -439,7 +439,7 @@ def parse_trade(self, trade, market=None):
symbol = market['symbol']
else:
symbol = marketId
orderId = trade[3]
orderId = str(trade[3])
takerOrMaker = 'maker' if (trade[8] == 1) else 'taker'
feeCost = trade[9]
feeCurrency = self.safe_currency_code(trade[10])
@@ -4,7 +4,7 @@

# -----------------------------------------------------------------------------

__version__ = '1.18.1149'
__version__ = '1.18.1150'

# -----------------------------------------------------------------------------

Some generated files are not rendered by default. Learn more.

@@ -58,13 +58,13 @@ If that does not help, please, follow here: https://github.com/nodejs/node-gyp#o

All-in-one browser bundle (dependencies included), served from a CDN of your choice:

* jsDelivr: https://cdn.jsdelivr.net/npm/ccxt@1.18.1149/dist/ccxt.browser.js
* unpkg: https://unpkg.com/ccxt@1.18.1149/dist/ccxt.browser.js
* jsDelivr: https://cdn.jsdelivr.net/npm/ccxt@1.18.1150/dist/ccxt.browser.js
* unpkg: https://unpkg.com/ccxt@1.18.1150/dist/ccxt.browser.js

You can obtain a live-updated version of the bundle by removing the version number from the URL (the `@a.b.c` thing) — however, we do not recommend to do that, as it may break your app eventually. Also, please keep in mind that we are not responsible for the correct operation of those CDN servers.

```HTML
<script type="text/javascript" src="https://cdn.jsdelivr.net/npm/ccxt@1.18.1149/dist/ccxt.browser.js"></script>
<script type="text/javascript" src="https://cdn.jsdelivr.net/npm/ccxt@1.18.1150/dist/ccxt.browser.js"></script>
```

Creates a global `ccxt` object:

0 comments on commit e15a04d

Please sign in to comment.