Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Use non deprecated tag keys PR causes bug #100

Closed
linhkikuchi opened this issue Jan 8, 2023 · 3 comments
Closed

Use non deprecated tag keys PR causes bug #100

linhkikuchi opened this issue Jan 8, 2023 · 3 comments
Labels
bug Something isn't working

Comments

@linhkikuchi
Copy link
Contributor

linhkikuchi commented Jan 8, 2023

Found a bug? Maybe our Slack Community can help.

Slack Community

Describe the Bug

Existing ASG with tags have this error The argument "tag.4.value" is required, but no definition was found. after upgrading to version 0.31.1. Can only do terraform apply if tags are removed.
(Changes from this PR #95)

Expected Behavior

Expected existing resources to have no change when upgrading from 0.31.0 to 0.31.1

Steps to Reproduce

Steps to reproduce the behavior:

  1. Create ASG resources from module cloudposse/ec2-autoscale-group/aws version 0.31.0
  2. Updating module version to 0.31.1
  3. Run terraform plan
  4. See error
Error: Missing required argument
│ 
│   with module.go_translate.module.autoscale_group.aws_autoscaling_group.default[0],
│   on .terraform/modules/go_translate.autoscale_group/main.tf line 144, in resource "aws_autoscaling_group" "default":
│  144: resource "aws_autoscaling_group" "default" {
│ 
│ The argument "tag.4.value" is required, but no definition was found.
╵

Anything that will help us triage the bug will help. Here are some ideas:

  • OS: [e.g. Linux, OSX, WSL, etc] OSX
  • Version [e.g. 10.15] 12.2
@linhkikuchi linhkikuchi added the bug Something isn't working label Jan 8, 2023
@nitrocode
Copy link
Member

How could this be fixed by the terraform?

If it cannot be fixed, is it better to document the path you described in order to upgrade from the old version to the new version?

@linhkikuchi
Copy link
Contributor Author

How could this be fixed by the terraform?

If it cannot be fixed, is it better to document the path you described in order to upgrade from the old version to the new version?

This can be fixed by remove empty/null values from tags https://github.com/cloudposse/terraform-aws-ec2-autoscale-group/pull/101/files#diff-dc46acf24afd63ef8c556b77c126ccc6e578bc87e3aa09a931f33d9bf2532fbbR142-R145

@linhkikuchi
Copy link
Contributor Author

Fixed by #101

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug Something isn't working
Projects
None yet
Development

No branches or pull requests

2 participants