Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Ruby bindings for SVN based on FFI
Ruby
branch: master

Merge pull request #2 from brandonvalentine/master

Update ffi_lib definitions to work on OS X and other non-standard install locations
latest commit 930a8da65f
@rdblue rdblue authored
Failed to load latest commit information.
lib Update ffi_lib definitions to work on OS X and possibly other non-sta…
spec Simplifying a test case.
test Updating rspec files.
.gitignore Updating rspec files.
.rspec Adding brand new rspec setup.
LICENSE Updating the copyright notice in LICENSE.
README Added to README
svn.gemspec

README

== About ==

This is a library for interacting with Subverison repositories. It is a
new set of ruby bindings that are simple to use and compatible with RVM
because they are dynamically linked to libsvn and do not require any native
extensions.

In addition, these new bindings expose a ruby-style API and try to hide the
underlying SVN details---for example, SVN separates repositories from their
inner filesystems, but this library hides that distinction.

== Getting Started ==

Example code:

 require 'svn'
 
 repo = Svn::Repo.open('/path/to/repo')
 r4 = repo.revision(4)
 puts "#{r}, by #{r.author} (on #{r.timestamp.strftime('%Y-%m-%d %H:%M')})\nLog: #{r.log}"
 
 r4.changes.each_pair { |path, changes| ... }
 puts r4.props.inspect
 # => {"svn:log"=>"...", "svn:author"=>"blue", "svn:date"=>"2011-10-14T23:51:58.705026Z"}
 puts r4.diff('/some/repo/file') # by default, against the previous revision

== Current Status ==

Version 0.1.0 supports read-only operations to inspect a subversion repository,
its files, and file properties. Transactions are planned and will be included
in a future version.

The current release, 0.1.0 is an experimental release and the API included is
subject to change. Rubygems version number conventions will be respected, so it
is recommended that callers specify the version of this library using the "~>"
operator:
 spec.add_dependency 'ffi', '~> 0.1'

== Contributing ==
Something went wrong with that request. Please try again.