Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Updated jeweler dep to 1.5.2

* Updated activesupport dep to 3.0.4
  • Loading branch information...
commit bc3fcf2d491e22e649f4bc6c90447e2137dcf721 1 parent 178e545
@dkubb dkubb authored
Showing with 35 additions and 38 deletions.
  1. +2 −2 Gemfile
  2. +2 −7 Rakefile
  3. +31 −26 dm-sqlite-adapter.gemspec
  4. +0 −3  tasks/spec.rake
View
4 Gemfile
@@ -24,7 +24,7 @@ group(:development) do # Development dependencies (as in the gemspec)
gem 'rake', '~> 0.8.7'
gem 'rspec', '~> 1.3.1'
- gem 'jeweler', '~> 1.4.0'
+ gem 'jeweler', '~> 1.5.2'
end
@@ -33,7 +33,7 @@ group :datamapper do # We need this because we want to pin these dependencies to
if ENV['EXTLIB']
gem 'extlib', '~> 0.9.15', SOURCE => "#{DATAMAPPER}/extlib#{REPO_POSTFIX}", :require => nil
else
- gem 'activesupport', '~> 3.0.3', :require => nil
+ gem 'activesupport', '~> 3.0.4', :require => nil
end
gem 'dm-core', DM_VERSION, SOURCE => "#{DATAMAPPER}/dm-core#{REPO_POSTFIX}"
View
9 Rakefile
@@ -2,7 +2,7 @@ require 'rubygems'
require 'rake'
begin
- gem 'jeweler', '~> 1.4'
+ gem 'jeweler', '~> 1.5.2'
require 'jeweler'
Jeweler::Tasks.new do |gem|
@@ -15,16 +15,11 @@ begin
gem.has_rdoc = 'yard'
gem.rubyforge_project = 'datamapper'
-
- gem.add_dependency 'do_sqlite3', '~> 0.10.2'
- gem.add_dependency 'dm-do-adapter', '~> 1.0.2'
-
- gem.add_development_dependency 'rspec', '~> 1.3'
end
Jeweler::GemcutterTasks.new
FileList['tasks/**/*.rake'].each { |task| import task }
rescue LoadError
- puts 'Jeweler (or a dependency) not available. Install it with: gem install jeweler'
+ puts 'Jeweler (or a dependency) not available. Install it with: gem install jeweler -v 1.5.2'
end
View
57 dm-sqlite-adapter.gemspec
@@ -1,6 +1,6 @@
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
+# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
@@ -9,59 +9,64 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Dan Kubb"]
- s.date = %q{2010-11-26}
+ s.date = %q{2011-02-19}
s.description = %q{Sqlite3 Adapter for DataMapper}
s.email = %q{dan.kubb@gmail.com}
s.extra_rdoc_files = [
"LICENSE"
]
s.files = [
- ".gitignore",
- "Gemfile",
- "LICENSE",
- "Rakefile",
- "VERSION",
- "dm-sqlite-adapter.gemspec",
- "lib/dm-sqlite-adapter.rb",
- "lib/dm-sqlite-adapter/adapter.rb",
- "lib/dm-sqlite-adapter/spec/setup.rb",
- "spec/adapter_spec.rb",
- "spec/rcov.opts",
- "spec/spec.opts",
- "spec/spec_helper.rb",
- "tasks/spec.rake",
- "tasks/yard.rake",
- "tasks/yardstick.rake"
+ "Gemfile",
+ "LICENSE",
+ "Rakefile",
+ "VERSION",
+ "dm-sqlite-adapter.gemspec",
+ "lib/dm-sqlite-adapter.rb",
+ "lib/dm-sqlite-adapter/adapter.rb",
+ "lib/dm-sqlite-adapter/spec/setup.rb",
+ "spec/adapter_spec.rb",
+ "spec/rcov.opts",
+ "spec/spec.opts",
+ "spec/spec_helper.rb",
+ "tasks/spec.rake",
+ "tasks/yard.rake",
+ "tasks/yardstick.rake"
]
- s.has_rdoc = %q{yard}
s.homepage = %q{http://github.com/datamapper/dm-sqlite-adapter}
- s.rdoc_options = ["--charset=UTF-8"]
s.require_paths = ["lib"]
s.rubyforge_project = %q{datamapper}
- s.rubygems_version = %q{1.3.7}
+ s.rubygems_version = %q{1.5.2}
s.summary = %q{Sqlite3 Adapter for DataMapper}
s.test_files = [
"spec/adapter_spec.rb",
- "spec/spec_helper.rb"
+ "spec/spec_helper.rb"
]
if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<do_sqlite3>, ["~> 0.10.2"])
s.add_runtime_dependency(%q<dm-do-adapter>, ["~> 1.0.2"])
- s.add_development_dependency(%q<rspec>, ["~> 1.3"])
+ s.add_development_dependency(%q<dm-migrations>, ["~> 1.0.2"])
+ s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
+ s.add_development_dependency(%q<rspec>, ["~> 1.3.1"])
+ s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
else
s.add_dependency(%q<do_sqlite3>, ["~> 0.10.2"])
s.add_dependency(%q<dm-do-adapter>, ["~> 1.0.2"])
- s.add_dependency(%q<rspec>, ["~> 1.3"])
+ s.add_dependency(%q<dm-migrations>, ["~> 1.0.2"])
+ s.add_dependency(%q<rake>, ["~> 0.8.7"])
+ s.add_dependency(%q<rspec>, ["~> 1.3.1"])
+ s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
end
else
s.add_dependency(%q<do_sqlite3>, ["~> 0.10.2"])
s.add_dependency(%q<dm-do-adapter>, ["~> 1.0.2"])
- s.add_dependency(%q<rspec>, ["~> 1.3"])
+ s.add_dependency(%q<dm-migrations>, ["~> 1.0.2"])
+ s.add_dependency(%q<rake>, ["~> 0.8.7"])
+ s.add_dependency(%q<rspec>, ["~> 1.3.1"])
+ s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
end
end
View
3  tasks/spec.rake
@@ -35,7 +35,4 @@ rescue LoadError
end
end
-task :spec => :check_dependencies
-task :rcov => :check_dependencies
-
task :default => :spec

0 comments on commit bc3fcf2

Please sign in to comment.
Something went wrong with that request. Please try again.