Permalink
Browse files

Remove old compatibility shims from d.c.gis.

  • Loading branch information...
1 parent f5d4b45 commit cebd8753c65ec33730f495bb7085f34884f7c3d6 @mjtamlyn mjtamlyn committed May 16, 2014
Showing with 2 additions and 10 deletions.
  1. +0 −9 django/contrib/gis/models.py
  2. +2 −1 docs/releases/1.8.txt
@@ -1,9 +0,0 @@
-from django.db import connection
-
-if (hasattr(connection.ops, 'spatial_version') and
- not connection.ops.mysql):
- # Getting the `SpatialRefSys` and `GeometryColumns`
- # models for the default spatial backend. These
- # aliases are provided for backwards-compatibility.
- SpatialRefSys = connection.ops.spatial_ref_sys()
- GeometryColumns = connection.ops.geometry_columns()
View
@@ -46,7 +46,8 @@ Minor features
:mod:`django.contrib.gis`
^^^^^^^^^^^^^^^^^^^^^^^^^^
-* ...
+* Compatibility shims for ``SpatialRefSys`` and ``GeometryColumns`` changed in
@timgraham

timgraham May 16, 2014

Owner

Shouldn't this be under "Backwards incompatible changes" not "Minor Features"?

+ Django 1.2 have been removed.
:mod:`django.contrib.messages`
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

0 comments on commit cebd875

Please sign in to comment.