Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

conflicting dependencies fog-core (~> 1.43.0) and fog-core (= 1.45.0) on Ubuntu 18.04 Final Beta #292

Closed
emhohensee opened this issue Apr 6, 2018 · 6 comments

Comments

@emhohensee
Copy link

@emhohensee emhohensee commented Apr 6, 2018

I just installed the Ubuntu 18.04 Final Beta and attempted to install the vagrant-vbguest plugin. Getting the following error. I can see from another issue that there have been version issues with fog-core and vagrant-libvirt before.

ethan@corvus:~$ vagrant plugin install vagrant-vbguest
Installing the 'vagrant-vbguest' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

conflicting dependencies fog-core (~> 1.43.0) and fog-core (= 1.45.0)
  Activated fog-core-1.45.0
  which does not match conflicting dependency (~> 1.43.0)

  Conflicting dependency chains:
    fog-core (= 1.45.0), 1.45.0 activated

  versus:
    vagrant-libvirt (> 0), 0.0.41 activated, depends on
    fog-core (~> 1.43.0)

Versions:

ethan@corvus:~$ vagrant version
Installed Version: 2.0.2
ethan@corvus:~$ ruby --version
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux-gnu]
@mihdan

This comment has been minimized.

Copy link

@mihdan mihdan commented Apr 11, 2018

Install Vagrant 2.0.3 from deb:

wget -c https://releases.hashicorp.com/vagrant/2.0.3/vagrant_2.0.3_x86_64.deb
sudo dpkg -i vagrant_2.0.3_x86_64.deb
@elgueromisa

This comment has been minimized.

Copy link

@elgueromisa elgueromisa commented May 9, 2018

The solution is install the newest vagrant version or as mihdan says...

@tjad

This comment has been minimized.

Copy link

@tjad tjad commented Jun 4, 2018

Issue can be close.

@allen-munsch

This comment has been minimized.

dholt added a commit to NVIDIA/deepops that referenced this issue Feb 11, 2019
* Virtual: install netaddr with system pkg

* Virtual: install working version of vagrant

See dotless-de/vagrant-vbguest#292
See https://bugs.launchpad.net/ubuntu/+source/vagrant/+bug/1796168

* Virtual: install libvirt-dev

Otherwise, you get errors compiling some gems while installing vagrant
plugins

* Virtual: become root to use vagrant

* Virtual: actually, don't do sudo+vagrant

* Virtual: install sshpass
@sleonardoaugusto

This comment has been minimized.

Copy link

@sleonardoaugusto sleonardoaugusto commented May 22, 2019

Version 2.0.3 not worked for me.

Solution:

wget -c https://releases.hashicorp.com/vagrant/2.2.4/vagrant_2.2.4_x86_64.deb
sudo dpkg -i vagrant_2.2.4_x86_64.deb
@gutierri

This comment has been minimized.

Copy link

@gutierri gutierri commented Oct 1, 2019

Thanks for the sugestion (@sleonardoaugusto ). In Debian 10 (buster), vagrant
2.2.4 The problem is fixed. The stable version of the repositories (2.2.3) does not.

dholt added a commit to dholt/deepops that referenced this issue Dec 4, 2019
* Virtual: install netaddr with system pkg

* Virtual: install working version of vagrant

See dotless-de/vagrant-vbguest#292
See https://bugs.launchpad.net/ubuntu/+source/vagrant/+bug/1796168

* Virtual: install libvirt-dev

Otherwise, you get errors compiling some gems while installing vagrant
plugins

* Virtual: become root to use vagrant

* Virtual: actually, don't do sudo+vagrant

* Virtual: install sshpass


Former-commit-id: 0e40a30
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
8 participants
You can’t perform that action at this time.