New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Accept IDs using unicode for C/C++ preprocessor (Origin: bugzilla #705219) #5253

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity normal in component general for ---
Reported in version 1.8.4-GIT on platform Other
Assigned to: Dimitri van Heesch

Original attachment names and IDs:

On 2013-08-01 00:41:59 +0000, Suzumizaki-Kimitaka wrote:

Created attachment 250572
fix to accept unicode characters with C/C++ preprocessors like #define

We should accept unicode (non ASCII) characters used with #define or any preprocessors.
See the specification of C++.

I made the patch for this problem, please apply this.

Regards,
Suzumizaki-Kimitaka

On 2013-08-01 19:29:07 +0000, Dimitri van Heesch wrote:

Thanks, I'll include the patch in the next GIT update.

On 2013-08-23 15:04:50 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.5. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant.

@doxygen doxygen closed this Jul 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment