New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Request: disable building documentation if Python 2.6 or newer not available (Origin: bugzilla #734828) #5548

Closed
doxygen opened this Issue Jul 2, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@doxygen
Owner

doxygen commented Jul 2, 2018

status RESOLVED severity normal in component build for ---
Reported in version 1.8.7 on platform Other
Assigned to: Dimitri van Heesch

On 2014-08-15 03:31:08 +0000, Misty De Meo wrote:

doxygen requires Python to build the documentation. However, the configure script doesn't try to detect whether a compatible version of Python is present; as a result, make may fail with an error from Python if the Python version on the system is too old. I can't find a documented required version, but it appears to be Python 2.6 since it uses the except Exception as ex syntax added in that version.

For example, this Tigerbrew package manager user (mistydemeo/tigerbrew#216) encountered a build failure when the OS-provided Python (2.4 or 2.5, I believe) exited with a SyntaxError exception due to not supporting the above exception syntax.

Incidentally, is it possible to disable building the doxygen docs? I couldn't find how.

On 2014-08-15 09:31:39 +0000, Dimitri van Heesch wrote:

Doxygen doesn't build the documentation by default. You need to do 'make docs' in order to build it.

Doxygen does need python 2.6+ for building. It runs several python scripts during the build.

I've already improved python detection in this commit:
SHA: 98a54c5

So can you please check if the issue is sufficiently addressed in the lastest snapshot from GitHub?

On 2014-08-17 17:58:30 +0000, Misty De Meo wrote:

Thanks! I didn't realize that it needed Python for anything other than the documentation - the updated build documentation and version checking looks good.

The update you added to the install documentation specifies that Python 2.7 is required to build, but the configure script checks for Python 2.6. which is the required version?

As well, would it be possible to change the shebang in src/configgen.py to not specify a particular Python interpreter path? For usecases like this one, where a newer Python is installed but not at /usr/bin, it's not very convenient.

On 2014-08-20 10:25:39 +0000, Dimitri van Heesch wrote:

It was tested with python 2.7 (since that is what I have myself), but according to the pyqver tool version 2.6 should also work.

I will mention 2.6 explicitly in the install section.

On 2014-08-21 17:15:07 +0000, Dimitri van Heesch wrote:

This bug was previously marked ASSIGNED, which means it should be fixed in
doxygen version 1.8.8. Please verify if this is indeed the case. Reopen the
bug if you think it is not fixed and please include any additional information
that you think can be relevant (preferrably in the form of a self-contained example).

@doxygen doxygen closed this Jul 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment