Skip to content
Permalink
Browse files

fix(generic): document that the minimum Node version is 6

  • Loading branch information
malept committed Dec 13, 2016
1 parent e76e282 commit 1f5ac7f2b69428d89adf14b7a5b4c2a36ccae004
Showing with 7 additions and 2 deletions.
  1. +2 −0 README.md
  2. +3 −0 package.json
  3. +1 −1 src/electron-forge.js
  4. +1 −1 src/util/check-system.js
@@ -16,6 +16,8 @@ jump right in to Electron development.

# Getting Started

**Note**: Electron Forge requires Node 6 or above, plus git installed.

```bash
npm install -g electron-forge
electron-forge init my-new-app
@@ -89,5 +89,8 @@
"electron-installer-debian": "^0.4.0",
"electron-installer-flatpak": "^0.4.0",
"electron-installer-redhat": "^0.3.0"
},
"engines": {
"node": ">= 6.0"
}
}
@@ -13,7 +13,7 @@ checkSystem()
checker.succeed();
if (!goodSystem) {
console.error(('It looks like you are missing some dependencies you need to get Electron running.\n' +
'Make sure you have git installed and node.js version 4.0.0+').red);
'Make sure you have git installed and Node.js version 6.0.0+').red);
process.exit(1);
}

@@ -8,4 +8,4 @@ export default async () =>
resolve(true);
});
})
.then(prev => Promise.resolve(prev && semver.gt(process.versions.node, '4.0.0')));
.then(prev => Promise.resolve(prev && semver.gt(process.versions.node, '6.0.0')));

0 comments on commit 1f5ac7f

Please sign in to comment.
You can’t perform that action at this time.