Skip to content

emutavchi/WebKitForWayland

master
Switch branches/tags
Code
This branch is 3610 commits ahead, 27113 commits behind WebPlatformForEmbedded:wpe-2.28.
Contribute

Latest commit

 

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

WPEWebKit

HTML5 score Donate

Building prerequisites

For Ubuntu 16.04 LTS (Xenial Xerus), please type:

$ sudo apt-get install intltool libtool-bin autoconf automake autopoint cmake gcc g++ bison flex gawk gperf ruby git libversion-perl libgnutls-dev libexpat-dev libxml2-dev libxslt-dev libsqlite3-dev libjpeg9-dev libfreetype6-dev libharfbuzz-dev libxcb-xkb-dev libwayland-dev libgbm-dev libgles2-mesa-dev libgstreamer1.0-dev libwebp-dev yasm ninja-build luajit libluajit-5.1-dev weston

Building

From the root directory, please type:

$ Tools/Scripts/update-webkitwpe-libs
$ Tools/Scripts/build-webkit --wpe

Running

If it is not already the case, you will need to execute a Wayland compositor.

To do this quickly under Ubuntu 16.04 LTS (Xenial Xerus), please type:

$ weston --socket=wpe

Then, to run WPEWebKit:

$ WAYLAND_DISPLAY=wpe Tools/Scripts/run-minibrowser --wpe
$ WAYLAND_DISPLAY=wpe Tools/Scripts/run-minibrowser --wpe http://www.bouncyballs.org

About

Unofficial mirror of the WebKit SVN repository

Resources

Stars

Watchers

Forks

Packages

No packages published