the sentry-raven.gemspec is asking faraday 0.8.0 rc2
gem.add_dependency "faraday", "~> 0.8.0.rc2"
While reading the faraday's changelog the 0.8 version seems to only impact get, head, delete https://github.com/technoweenie/faraday/wiki/Changelog.
Can the requirements to faraday be >=0.7.6? Lots of projects have not stepped to 0.8. This could avoid conflicts in Gemfile. raven-ruby doesn't need the 0.8 version (I've ran the raven-ruby tests in 0.7.6 and they all passe)
Test coverage is almost nothing right now, so that isn't a good indicator. 0.8 added the new syntax for middleware stuffs. It could probably be reverted to the old one, patches welcome.
We've stepped the faraday version requirement down to 0.7.6.