does faraday version requirement needs to be ~> 0.8? #6

hellvinz opened this Issue May 9, 2012 · 2 comments


None yet

3 participants

hellvinz commented May 9, 2012

the sentry-raven.gemspec is asking faraday 0.8.0 rc2

 gem.add_dependency "faraday", "~> 0.8.0.rc2"

While reading the faraday's changelog the 0.8 version seems to only impact get, head, delete

Can the requirements to faraday be >=0.7.6? Lots of projects have not stepped to 0.8. This could avoid conflicts in Gemfile. raven-ruby doesn't need the 0.8 version (I've ran the raven-ruby tests in 0.7.6 and they all passe)



Test coverage is almost nothing right now, so that isn't a good indicator. 0.8 added the new syntax for middleware stuffs. It could probably be reverted to the old one, patches welcome.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment