Skip to content
This repository has been archived by the owner on Oct 31, 2023. It is now read-only.

Commit

Permalink
Browse files Browse the repository at this point in the history
fix(deps): pin 'google-{api,cloud}-core', 'google-auth' to allow 2.x …
…versions (#234)

Expand pins on library dependencies in preparation for these dependencies taking a new major version. See googleapis/google-cloud-python#10566.
  • Loading branch information
busunkim96 committed Jul 20, 2021
1 parent 5816a45 commit 0687c84
Showing 1 changed file with 4 additions and 1 deletion.
5 changes: 4 additions & 1 deletion setup.py
Expand Up @@ -28,7 +28,10 @@
# 'Development Status :: 5 - Production/Stable'
release_status = "Development Status :: 5 - Production/Stable"
dependencies = [
"google-api-core[grpc] >= 1.26.0, < 2.0.0dev",
# NOTE: Maintainers, please do not require google-api-core>=2.x.x
# Until this issue is closed
# https://github.com/googleapis/google-cloud-python/issues/10566
"google-api-core[grpc] >= 1.26.0, <3.0.0dev",
"grpc-google-iam-v1 >= 0.12.3, < 0.13dev",
"google-cloud-access-context-manager >= 0.1.2, < 0.2.0dev",
"google-cloud-org-policy>=0.1.2, <2.0.0",
Expand Down

0 comments on commit 0687c84

Please sign in to comment.