Skip to content
This repository has been archived by the owner on Oct 31, 2023. It is now read-only.

Commit

Permalink
Browse files Browse the repository at this point in the history
feat!: move to microgenerator (#58)
* feat!: move to microgenerator

* update UPGRADING.md

* rebase after the samples are moved

* update sample

* update sample

* update sample

* update sample

* fix linter

* fix linter
  • Loading branch information
arithmetic1728 committed Aug 5, 2020
1 parent 00b43e8 commit 3219b64
Show file tree
Hide file tree
Showing 238 changed files with 25,630 additions and 21,703 deletions.
13 changes: 6 additions & 7 deletions .coveragerc
Expand Up @@ -21,15 +21,14 @@ branch = True
[report]
fail_under = 100
show_missing = True
omit = google/cloud/asset/__init__.py
exclude_lines =
# Re-enable the standard pragma
pragma: NO COVER
# Ignore debug-only repr
def __repr__
# Ignore abstract methods
raise NotImplementedError
omit =
*/gapic/*.py
*/proto/*.py
*/core/*.py
*/site-packages/*.py
# Ignore pkg_resources exceptions.
# This is added at the module level as a safeguard for if someone
# generates the code and tries to run it without pip installing. This
# makes it virtually impossible to test properly.
except pkg_resources.DistributionNotFound
6 changes: 4 additions & 2 deletions README.rst
Expand Up @@ -48,11 +48,13 @@ dependencies.

Supported Python Versions
^^^^^^^^^^^^^^^^^^^^^^^^^
Python >= 3.5
Python >= 3.6

Deprecated Python Versions
^^^^^^^^^^^^^^^^^^^^^^^^^^
Python == 2.7. Python 2.7 support will be removed on January 1, 2020.
Python == 2.7.

The last version of this library compatible with Python 2.7 is google-cloud-asset==1.3.0.


Mac/Linux
Expand Down
162 changes: 162 additions & 0 deletions UPGRADING.md
@@ -0,0 +1,162 @@
# 2.0.0 Migration Guide

The 2.0 release of the `google-cloud-asset` client is a significant upgrade based on a [next-gen code generator](https://github.com/googleapis/gapic-generator-python), and includes substantial interface changes. Existing code written for earlier versions of this library will likely require updates to use this version. This document describes the changes that have been made, and what you need to do to update your usage.

If you experience issues or have questions, please file an [issue](https://github.com/googleapis/python-asset/issues).

## Supported Python Versions

> **WARNING**: Breaking change
The 2.0.0 release requires Python 3.6+.


## Method Calls

> **WARNING**: Breaking change
Methods expect request objects. We provide a script that will convert most common use cases.

* Install the library

```py
python3 -m pip install google-cloud-asset
```

* The script `fixup_asset_v1_keywords.py` is shipped with the library. It expects
an input directory (with the code to convert) and an empty destination directory.

```sh
$ fixup_asset_v1_keywords.py --input-directory .samples/ --output-directory samples/
```

**Before:**
```py
from google.cloud import asset

client = asset.AssetServiceClient()

feeds = client.list_feeds("folders/12345")
```


**After:**
```py
from google.cloud import asset

client = asset.AssetServiceClient()

feeds = client.list_feeds(request = {'parent': "folders/12345"})
```

### More Details

In `google-cloud-asset<2.0.0`, parameters required by the API were positional parameters and optional parameters were keyword parameters.

**Before:**
```py
def search_all_resources(
self,
scope,
query=None,
asset_types=None,
page_size=None,
order_by=None,
retry=google.api_core.gapic_v1.method.DEFAULT,
timeout=google.api_core.gapic_v1.method.DEFAULT,
metadata=None,
):
```

In the 2.0.0 release, all methods have a single positional parameter `request`. Method docstrings indicate whether a parameter is required or optional.

Some methods have additional keyword only parameters. The available parameters depend on the `google.api.method_signature` annotation specified by the API producer.


**After:**
```py
def search_all_resources(
self,
request: asset_service.SearchAllResourcesRequest = None,
*,
scope: str = None,
query: str = None,
asset_types: Sequence[str] = None,
retry: retries.Retry = gapic_v1.method.DEFAULT,
timeout: float = None,
metadata: Sequence[Tuple[str, str]] = (),
) -> pagers.SearchAllResourcesPager:
```

> **NOTE:** The `request` parameter and flattened keyword parameters for the API are mutually exclusive.
> Passing both will result in an error.

Both of these calls are valid:

```py
response = client.search_all_resources(
request={
"scope": scope,
"query": query,
"asset_types": asset_types,
}
)
```

```py
response = client.search_all_resources(
scope=scope,
query=query,
asset_types=asset_types
)
```

This call is invalid because it mixes `request` with a keyword argument `asset_types`. Executing this code
will result in an error.

```py
response = client.search_all_resources(
request={
"scope": scope,
"query": query,
},
asset_types=asset_types
)
```



## Enums and Types


> **WARNING**: Breaking change
The submodules `enums` and `types` have been removed.

**Before:**
```py
from google.cloud import asset

resource = asset.enums.ContentType.RESOURCE
cloud_asset = asset.types.Asset(name="name")
```


**After:**
```py
from google.cloud import asset

resource = asset.ContentType.RESOURCE
cloud_asset = asset.Asset(name="name")
```

## Project Path Helper Methods

The project path helper method `project_path` has been removed. Please construct
this path manually.

```py
project = 'my-project'
project_path = f'projects/{project}'
```
1 change: 1 addition & 0 deletions docs/UPGRADING.md
6 changes: 6 additions & 0 deletions docs/asset_v1/services.rst
@@ -0,0 +1,6 @@
Services for Google Cloud Asset v1 API
======================================

.. automodule:: google.cloud.asset_v1.services.asset_service