Skip to content
Language extension for NSIS
Java Other
  1. Java 99.4%
  2. Other 0.6%
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
dist
lib
src Updated release notes Dec 3, 2014
.classpath
.gitignore
.project
LICENSE
README.md
build.gradle
build.xml

README.md

BridleNSIS

BridleNSIS is a language extension for NSIS (Nullsoft Scriptable Install System) designed to make things easier to express and rein in verbosity of NSIS at places.

Latest version: 0.4.1

Build From Source Code

Build from source code requires JDK 1.7 or newer, NSIS, and either Apache Ant 1.8 (or newer) or Gradle 2.0.

  1. Compile BridleNSIS Java classes: >ant|gradle classes
  2. Compile and run tests: >ant|gradle test
  3. Create distribution jar package: >ant|gradle jar
  4. Generate documentation: >ant|gradle doc
  5. Compile installer: >ant|gradle installer

Or simply build all by >ant|gradle.

You can’t perform that action at this time.