Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Feature request: tags #1

Closed
rdouma opened this Issue · 14 comments

5 participants

@rdouma

It would be great if tags could be set directly from the plug-in. And even better if they would be initialized with the Aperture tags assigned :-)

@iKenndac
Owner

Great idea - I'll look into it!

@rdouma

Awesome! :-)

@iKenndac
Owner

It appears that the 500px API doesn't support setting tags at this time - could be wrong though. I'll email them for clarification.

@rdouma
@williamli

hope 500px can add tag support in API soon...

@iKenndac
Owner

Me too! You should email them and ask for it. The more people that do, the faster it'll happen!

@williamli

btw, doesn't the photo file itself contains the keywords / tags anyway?
the tags are there when i export files manually from Aperture and upload them via web interface.

@williamli

i tweeted them @500px
hope more people can see this and contact 500px regarding it.
thanks for the plugin :)

@williamli

and i think i just got you a respond: @iKenndac API does support tags, the docs are lagging behind though. I'll get to fixing that situation as soon as.

@rdouma

Isn't the internet an amazing thing? :-)

@freeatnet

@williamli Hi. That was me on Twitter. I'm with 500px and we do indeed have API support for tags. We're late on documenting it though, but I intend on getting to fixing it as soon as I can.

@williamli

hi @freeatnet are you working with 500px?

@iKenndac
Owner

I'd like to politely point out that this is an issue tracker, not a chat client or Twitter. Only messages actually helpful to the issue at hand please, since I get an email each time someone comments.

@glaurent

Hi,

I was about to try adding a preference setting to filter keywords on export but just realised that keywords/tags aren't currently supported :-). Has there been any update on this since then ? If the API is available (Google couldn't find anything), I'm willing to help.

@iKenndac iKenndac referenced this issue from a commit
Daniel Kennett Hack to make tag setting work most of the time. (GitHub Issue #1)
Since we can't set tags on upload because 500px takes some time to process the photo, we try once every 5 seconds for up to a minute to set the tags.
8e9177b
@iKenndac iKenndac closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.