Permalink
Fetching contributors…
Cannot retrieve contributors at this time
148 lines (136 sloc) 5.11 KB
<?xml version='1.0' encoding='UTF-8'?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.jboss</groupId>
<artifactId>jboss-parent</artifactId>
<version>10</version>
</parent>
<groupId>org.jboss.spec.javax.ejb</groupId>
<artifactId>jboss-ejb-api_3.2_spec</artifactId>
<version>1.0.1.Final-SNAPSHOT</version>
<packaging>jar</packaging>
<name>Enterprise JavaBeans(TM) 3.2 API</name>
<description>JSR 345: Enterprise JavaBeans(TM) 3.2 API</description>
<licenses>
<license>
<name>Common Development and Distribution License</name>
<url>http://repository.jboss.org/licenses/cddl.txt</url>
<distribution>repo</distribution>
</license>
<license>
<name>GNU General Public License, Version 2 with the Classpath Exception</name>
<url>http://repository.jboss.org/licenses/gpl-2.0-ce.txt</url>
<distribution>repo</distribution>
</license>
</licenses>
<scm>
<connection>scm:git:git@github.com:jboss/jboss-ejb-api_spec.git</connection>
<developerConnection>scm:git:git@github.com:jboss/jboss-ejb-api_spec.git</developerConnection>
<url>https://github.com/jboss/jboss-ejb-api_spec</url>
<tag>HEAD</tag>
</scm>
<properties>
<!-- This property is used by the maven enforcer and maven compiler plugins configured in the parent pom
(jboss-parent). We override the value here to 1.7 to force our project to require Java 7 -->
<maven.compiler.source>1.7</maven.compiler.source>
<maven.compiler.target>1.7</maven.compiler.target>
</properties>
<build>
<plugins>
<!-- Include LICENSE.txt in the META-INF directory -->
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-resources-plugin</artifactId>
<executions>
<execution>
<id>copy-resources</id>
<phase>process-resources</phase>
<goals>
<goal>copy-resources</goal>
</goals>
<configuration>
<resources>
<resource>
<directory>${basedir}</directory>
<includes>
<include>LICENSE</include>
<include>README</include>
</includes>
</resource>
</resources>
<outputDirectory>${project.build.outputDirectory}/META-INF</outputDirectory>
</configuration>
</execution>
</executions>
</plugin>
<!-- Generate the OSGi jar Manifest. -->
<plugin>
<groupId>org.apache.felix</groupId>
<artifactId>maven-bundle-plugin</artifactId>
<executions>
<execution>
<id>bundle-manifest</id>
<phase>process-classes</phase>
<goals>
<goal>manifest</goal>
</goals>
</execution>
</executions>
<configuration>
<archive>
<manifest>
<addDefaultSpecificationEntries>false</addDefaultSpecificationEntries>
</manifest>
</archive>
<instructions>
<Specification-Title>Enterprise JavaBeans(TM) 3.2 API</Specification-Title>
<Specification-Vendor>Oracle</Specification-Vendor>
<Specification-Version>3.2</Specification-Version>
<!-- Set the package version to match the spec version -->
<Export-Package>
javax.ejb*;version=3.2
</Export-Package>
</instructions>
</configuration>
</plugin>
<!-- Add the OSGi Manifest to the main jar -->
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-jar-plugin</artifactId>
<configuration>
<archive>
<manifestFile>${project.build.outputDirectory}/META-INF/MANIFEST.MF</manifestFile>
</archive>
</configuration>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-source-plugin</artifactId>
<configuration>
<archive>
<manifestEntries>
<Specification-Title>Enterprise JavaBeans(TM) 3.2 API</Specification-Title>
<Specification-Vendor>Oracle</Specification-Vendor>
<Specification-Version>3.2</Specification-Version>
</manifestEntries>
</archive>
</configuration>
</plugin>
</plugins>
</build>
<dependencies>
<dependency>
<groupId>org.jboss.spec.javax.transaction</groupId>
<artifactId>jboss-transaction-api_1.2_spec</artifactId>
<version>1.0.0.Final</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.jboss.spec.javax.xml.rpc</groupId>
<artifactId>jboss-jaxrpc-api_1.1_spec</artifactId>
<version>1.0.1.Final</version>
<scope>provided</scope>
</dependency>
</dependencies>
</project>