Custom menu with a placeholder highlights first element in 1.1 Final and RC2 although it's not selected #4061

Closed
brunnsbe opened this Issue Apr 16, 2012 · 2 comments

Comments

Projects
None yet
4 participants
@brunnsbe

Compare
http://jquerymobile.com/demos/1.1.0/docs/forms/selects/custom.html
or
http://jquerymobile.com/demos/1.1.0-rc.2/docs/forms/selects/custom.html

with

http://jquerymobile.com/demos/1.1.0-rc.1/docs/forms/selects/custom.html
or
http://jquerymobile.com/demos/1.0/docs/forms/selects/custom.html

Go to "Placeholder options" and click on one of the three available demo custom selects.

Previously no element was highlighted, now in 1.1 Final and 1.1-RC2 the first element is automatically shown as selected.

I guess this fix caused this issue:
94f45ff

@jaspermdegroot

This comment has been minimized.

Show comment
Hide comment
@jaspermdegroot

jaspermdegroot Jun 21, 2012

Member

To do: items should get hover style on focus, including the first item that gets focus when the menu is opened

As discussed with @gabrielschulhof I will take care of that.

Member

jaspermdegroot commented Jun 21, 2012

To do: items should get hover style on focus, including the first item that gets focus when the menu is opened

As discussed with @gabrielschulhof I will take care of that.

@gabrielschulhof

This comment has been minimized.

Show comment
Hide comment
@gabrielschulhof

gabrielschulhof Jun 25, 2012

Contributor

Just pushed the above todo. Closing ...

Contributor

gabrielschulhof commented Jun 25, 2012

Just pushed the above todo. Closing ...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment