Skip to content
Yet Another MapKit.framework based on Google Maps Javascript API.
Objective-C C++
Find file
Latest commit 8bccc39 @kishikawakatsumi Refactoring.
Failed to load latest commit information.
Demo Refactoring.
Framework Refactoring.
.gitignore Initial commit
LICENSE Update README.
README.md Update README.md

README.md

YAMapKit - Yet Another MapKit.framework

YAMapKit based on Google Maps Javascript API. Inspired by MacMapKit.
You can use Google Maps on iOS 6 just link this library in your application. YAMapKit is compatible with MapKit.framework.


ScreenShot1  ScreenShot2  ScreenShot3  ScreenShot4  ScreenShot5  ScreenShot6 

It Works

YAMapKit implements nearly 100% of MK* functionality. It's been tested on iOS 5 and 6.

Unsupported Features

  • Geocoding. (Use 'CLGeocoder' instead.)
  • Custom overlay views. (Supported builtin classes only. e.g. MKPolylineView, MKCircleView and so on.)
  • Raplace annotation by 'Drag & Drop'.

What's Provided

There's currently a framework and a small demo application.

Documentation

Because the framework is API compatible with Apple's, you can use their documentation as a reference.

Usage

  1. Unlink Apple's MapKit.framework.
  2. Link libMapKit.a
  3. Link CoreLocation.framework

Build Settings

Original code

MacMapKit
https://github.com/Oomph/MacMapKit MacMapKit is distributed under the BSD license. However, MacMapKit uses Google services to provide map data. Use of specific classes of this framework (and their associated interfaces) binds you to the Google Maps/Google Earth API terms of service. You can find these terms of service at http://code.google.com/apis/maps/terms.html.

License

YAMapKit is available under the MIT license. See the LICENSE file for more info.

Something went wrong with that request. Please try again.