Skip to content

Loading…

Check for ICU library version >=4.1.4 #482

Closed
artemp opened this Issue · 5 comments

1 participant

@artemp
Mapnik member

At the moment we use 'fromUTF32' which is only in ICU >=4.1.4

@artemp
Mapnik member

[springmeyer] This looks like it was added to ICU one year ago: http://bugs.icu-project.org/trac/ticket/6677

@artemp
Mapnik member

[springmeyer] it was assigned to milestone 4.1.4, so I'm assuming that is the min release.

@artemp
Mapnik member

[springmeyer] r1597 disables regex support for ICU versions lacking fromUTF32. needs work...

@artemp
Mapnik member

[springmeyer] added as a configure time check in r2431, re-assigning to artem to take a look and close if it is adequate (and if we do not instead wish to add back support for earlier versions of icu)

@artemp
Mapnik member

[springmeyer] closing.

@artemp artemp closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.