Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Bug] Japanese introduction string is incomplete. Shows %s. #3741

Open
birtles opened this issue Jun 27, 2019 · 9 comments

Comments

Projects
None yet
8 participants
@birtles
Copy link

commented Jun 27, 2019

Steps to reproduce

  1. Open Firefox Preview on a Japanese device

Expected behavior

Something sensible is displayed.

Actual behavior

The string: "Firefox Preview へようこそ!%s を知ろう" is displayed
Screenshot_20190628-080926

Device information

  • Android device: Pixel 3
  • Fenix version: 1.0.0 (Build #11721515 Gecko 68.0-20190611143747)

@birtles birtles added the 🐞 bug label Jun 27, 2019

@NotWoods NotWoods added the 🌐 L10N label Jun 27, 2019

@kbrosnan

This comment has been minimized.

Copy link
Contributor

commented Jun 27, 2019

When we released it was noted that there was one Japanese string that was not translated. Is this the problem that was called out @Delphine ?

@Delphine

This comment has been minimized.

Copy link
Contributor

commented Jun 28, 2019

The placeholder '%s ' should be rendering as the app name. No idea why it's not in this case. Will poke around

@birtles

This comment has been minimized.

Copy link
Author

commented Jun 28, 2019

Let me know if I can help with any additional information.

@flodolo

This comment has been minimized.

Copy link

commented Jun 28, 2019

CC @marsf

The string was fixed 4 days ago, so it's not in the MVP. The original translation wasn't using %s, just something that looks like it %s, and breaks the replacement.

Note that we already fixed a bunch of these errors in Japanese when we enabled checks in Transvision (example), but this error was introduced after.

@divya21raj

This comment has been minimized.

Copy link
Contributor

commented Jun 28, 2019

On it, will make a PR

divya21raj added a commit to divya21raj/fenix that referenced this issue Jun 28, 2019

@divya21raj

This comment has been minimized.

Copy link
Contributor

commented Jun 28, 2019

Fixed, problem was % instead of % in the code for some reason.

@flodolo

This comment has been minimized.

Copy link

commented Jun 28, 2019

On it, will make a PR

I don't think you should, because it's going to mess with automation (@Pike would know for sure).

Note that the string has already been fixed, we only need to export new translations to the repository. Also, that won't affected the current MVP, just next releases.

@Pike

This comment has been minimized.

Copy link
Contributor

commented Jun 28, 2019

This is already in #3592, wating to merge.

@marsf

This comment has been minimized.

Copy link

commented Jun 28, 2019

It was introduced by my fault.
'%' is Japanese full-width character. It shouldn't be used in l10n.

colintheshots added a commit that referenced this issue Jun 28, 2019

Fixed Issue #3741 - %s in Japanese version + A few typos (#3749)
* Typo in README

* Fixed Issue #3741 - %s in Japanese version

* Fixed various typos
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.