Skip to content
Permalink
Browse files

build: log the found compiler version if too old

`configure` will log a warning if the detected compiler is not new
enough. Take some of the guesswork out of it by also logging the
version of the compiler that was detected.

PR-URL: #30028
Reviewed-By: Sam Roberts <vieuxtech@gmail.com>
Reviewed-By: Colin Ihrig <cjihrig@gmail.com>
Reviewed-By: Luigi Pinca <luigipinca@gmail.com>
Reviewed-By: Anna Henningsen <anna@addaleax.net>
Reviewed-By: Jiawen Geng <technicalcute@gmail.com>
Reviewed-By: David Carlier <devnexen@gmail.com>
  • Loading branch information
richardlau authored and targos committed Oct 18, 2019
1 parent 870c320 commit a86648c8d2890203f7fe69db6daeceaa44e12329
Showing with 4 additions and 2 deletions.
  1. +4 −2 configure.py
@@ -773,7 +773,8 @@ def check_compiler(o):
if not ok:
warn('failed to autodetect C++ compiler version (CXX=%s)' % CXX)
elif clang_version < (8, 0, 0) if is_clang else gcc_version < (6, 3, 0):
warn('C++ compiler too old, need g++ 6.3.0 or clang++ 8.0.0 (CXX=%s)' % CXX)
warn('C++ compiler (CXX=%s, %s) too old, need g++ 6.3.0 or clang++ 8.0.0' %
(CXX, ".".join(map(str, clang_version if is_clang else gcc_version))))

ok, is_clang, clang_version, gcc_version = try_check_compiler(CC, 'c')
if not ok:
@@ -782,7 +783,8 @@ def check_compiler(o):
# clang 3.2 is a little white lie because any clang version will probably
# do for the C bits. However, we might as well encourage people to upgrade
# to a version that is not completely ancient.
warn('C compiler too old, need gcc 4.2 or clang 3.2 (CC=%s)' % CC)
warn('C compiler (CC=%s, %s) too old, need gcc 4.2 or clang 3.2' %
(CC, ".".join(map(str, gcc_version))))

o['variables']['llvm_version'] = get_llvm_version(CC) if is_clang else '0.0'

0 comments on commit a86648c

Please sign in to comment.
You can’t perform that action at this time.