Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Object.entries is not compatible with < iOS 10.3 after 6.4.14 #4341

Closed
doxiaodong opened this issue Mar 17, 2021 · 0 comments
Closed

Object.entries is not compatible with < iOS 10.3 after 6.4.14 #4341

doxiaodong opened this issue Mar 17, 2021 · 0 comments

Comments

@doxiaodong
Copy link

@doxiaodong doxiaodong commented Mar 17, 2021

  • Swiper Version: e0d1909.
  • Platform/Target and Browser Versions: < iOS 10.2

What You Did

Nothing

Expected Behavior

Compatible with iOS 9+

Maybe add acorn for es5 checking is a stable way

try {
  require('acorn').parse(source, {
    ecmaVersion: 5
  });
} catch (error) {process.exit(1)}
@doxiaodong doxiaodong changed the title Object.entries is not compatible with < iOS 10.3 Object.entries is not compatible with < iOS 10.3 after 6.14.0 Mar 17, 2021
@doxiaodong doxiaodong changed the title Object.entries is not compatible with < iOS 10.3 after 6.14.0 Object.entries is not compatible with < iOS 10.3 after 6.4.14 Mar 17, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

1 participant