Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Error: installing lotte with 1.1.0-beta-7 (works with 1.0.x) #1978

Closed
StanAngeloff opened this Issue · 0 comments

2 participants

@StanAngeloff

EDIT: I looked at #1888, but it did not help.

npm shipping with Node 0.6.x fails to install a package (lotte) which previously worked on the 1.0.x series.

vagrant@lucid32:~$ npm -v
1.1.0-beta-6

vagrant@lucid32:~$ sudo npm install -g npm@1.0.106
npm http GET https://registry.npmjs.org/npm/1.0.106
npm http 200 https://registry.npmjs.org/npm/1.0.106
npm http GET https://registry.npmjs.org/npm/-/npm-1.0.106.tgz
npm http 200 https://registry.npmjs.org/npm/-/npm-1.0.106.tgz
/usr/local/bin/npm -> /usr/local/lib/node_modules/npm/bin/npm-cli.js
/usr/local/bin/npm_g -> /usr/local/lib/node_modules/npm/bin/npm-cli.js
/usr/local/bin/npm-g -> /usr/local/lib/node_modules/npm/bin/npm-cli.js
npm@1.0.106 /usr/local/lib/node_modules/npm 

vagrant@lucid32:~$ npm -v
1.0.106

vagrant@lucid32:~$ sudo npm install -g lotte
/usr/local/bin/lotte -> /usr/local/lib/node_modules/lotte/bin/cli.js
lotte@0.1.2-1 /usr/local/lib/node_modules/lotte 
├── naturalsort@0.0.1
├── semver@1.0.13
├── minimatch@0.0.5 (lru-cache@1.0.5)
├── optimist@0.2.8 (wordwrap@0.0.2)
└── findit@0.1.2

vagrant@lucid32:~$ lotte -v
lotte 0.1.2-1

Upgrading to the latest alpha (at the time of writing this is 1.1.0-beta-7) then fails to install the package from the repository:

vagrant@lucid32:~$ sudo npm cache clean

vagrant@lucid32:~$ sudo npm install -g npm@alpha
/usr/local/bin/npm -> /usr/local/lib/node_modules/npm/bin/npm-cli.js
/usr/local/bin/npm_g -> /usr/local/lib/node_modules/npm/bin/npm-cli.js
/usr/local/bin/npm-g -> /usr/local/lib/node_modules/npm/bin/npm-cli.js
npm@1.1.0-beta-7 /usr/local/lib/node_modules/npm 

vagrant@lucid32:~$ npm -v
1.1.0-beta-7

vagrant@lucid32:~$ sudo npm uninstall -g lotte

vagrant@lucid32:~$ sudo npm cache clean

vagrant@lucid32:~$ sudo npm install -g lotte
npm http GET https://registry.npmjs.org/findit
npm http GET https://registry.npmjs.org/minimatch
npm http GET https://registry.npmjs.org/naturalsort
npm http GET https://registry.npmjs.org/optimist
npm http GET https://registry.npmjs.org/semver
npm http 200 https://registry.npmjs.org/findit
npm http GET https://registry.npmjs.org/findit/-/findit-0.1.2.tgz
npm http 200 https://registry.npmjs.org/naturalsort
npm http GET https://registry.npmjs.org/naturalsort/-/naturalsort-0.0.1.tgz
npm http 200 https://registry.npmjs.org/minimatch
npm http GET https://registry.npmjs.org/minimatch/-/minimatch-0.0.5.tgz
npm http 200 https://registry.npmjs.org/optimist
npm http GET https://registry.npmjs.org/optimist/-/optimist-0.2.8.tgz
npm http 200 https://registry.npmjs.org/semver
npm http GET https://registry.npmjs.org/semver/-/semver-1.0.13.tgz
npm http 200 https://registry.npmjs.org/naturalsort/-/naturalsort-0.0.1.tgz
npm http 200 https://registry.npmjs.org/findit/-/findit-0.1.2.tgz
npm http 200 https://registry.npmjs.org/minimatch/-/minimatch-0.0.5.tgz
npm http 200 https://registry.npmjs.org/semver/-/semver-1.0.13.tgz
npm http 200 https://registry.npmjs.org/optimist/-/optimist-0.2.8.tgz
npm http GET https://registry.npmjs.org/lru-cache
npm http GET https://registry.npmjs.org/seq
npm http GET https://registry.npmjs.org/wordwrap
npm http 200 https://registry.npmjs.org/lru-cache
npm http GET https://registry.npmjs.org/lru-cache/-/lru-cache-1.0.5.tgz
npm http 200 https://registry.npmjs.org/wordwrap
npm http GET https://registry.npmjs.org/wordwrap/-/wordwrap-0.0.2.tgz
npm http 200 https://registry.npmjs.org/seq
npm http GET https://registry.npmjs.org/seq/-/seq-0.3.5.tgz
npm http 200 https://registry.npmjs.org/lru-cache/-/lru-cache-1.0.5.tgz
npm http 200 https://registry.npmjs.org/wordwrap/-/wordwrap-0.0.2.tgz
npm http 200 https://registry.npmjs.org/seq/-/seq-0.3.5.tgz
npm http GET https://registry.npmjs.org/chainsaw
npm http GET https://registry.npmjs.org/hashish
npm http 200 https://registry.npmjs.org/chainsaw
npm http GET https://registry.npmjs.org/chainsaw/-/chainsaw-0.0.9.tgz
npm http 200 https://registry.npmjs.org/hashish
npm http GET https://registry.npmjs.org/hashish/-/hashish-0.0.4.tgz
npm http 200 https://registry.npmjs.org/chainsaw/-/chainsaw-0.0.9.tgz
npm http 200 https://registry.npmjs.org/hashish/-/hashish-0.0.4.tgz
npm http GET https://registry.npmjs.org/traverse
npm http GET https://registry.npmjs.org/traverse
npm http 200 https://registry.npmjs.org/traverse
npm http 200 https://registry.npmjs.org/traverse
npm http GET https://registry.npmjs.org/traverse/-/traverse-0.3.9.tgz
npm http GET https://registry.npmjs.org/traverse/-/traverse-0.5.2.tgz
npm http 200 https://registry.npmjs.org/traverse/-/traverse-0.5.2.tgz
npm http 200 https://registry.npmjs.org/traverse/-/traverse-0.3.9.tgz
npm ERR! error installing lotte@0.1.2-1
npm ERR! Error: ENOENT, no such file or directory '/usr/local/lib/node_modules/lotte/bin/cli.js'
npm ERR! Report this *entire* log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>
npm ERR! 
npm ERR! System Linux 2.6.32-33-generic
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "lotte"
npm ERR! cwd /home/vagrant
npm ERR! node -v v0.6.6
npm ERR! npm -v 1.1.0-beta-7
npm ERR! path /usr/local/lib/node_modules/lotte/bin/cli.js
npm ERR! code ENOENT
npm ERR! message ENOENT, no such file or directory '/usr/local/lib/node_modules/lotte/bin/cli.js'
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/vagrant/npm-debug.log
npm not ok

Verbose log file is available as a Gist. Happy to provide any additional information.

@mfncooper mfncooper closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.