Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error when defining bus binding #39

Closed
juli1 opened this issue Oct 21, 2013 · 3 comments
Closed

Error when defining bus binding #39

juli1 opened this issue Oct 21, 2013 · 3 comments

Comments

@juli1
Copy link
Contributor

@juli1 juli1 commented Oct 21, 2013

When defining error propagation on bus bindings, it seems that the keyword bus is not recognized. Please see the model below on line 130.

https://gist.github.com/juli1/7089500

@reteprelief
Copy link
Contributor

@reteprelief reteprelief commented Oct 21, 2013

What is a bus binding? Are you talking about a connection binding? The keyword for that is "connection".
Connection bindings bind to buses, systems, processors, virtual bus. Thus, we use the keyword "connection" - the same as used in the binding properties.

@juli1
Copy link
Contributor Author

@juli1 juli1 commented Oct 21, 2013

In that case, we should change the standard since the keyword is allowed (see p 32 of the emv2 standard)

@juli1
Copy link
Contributor Author

@juli1 juli1 commented Oct 21, 2013

fixed in latest revision

@juli1 juli1 closed this Oct 21, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.