Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to find archetypes directory #33

Open
simonszu opened this issue May 17, 2017 · 6 comments

Comments

@simonszu
Copy link
Contributor

commented May 17, 2017

When creating a new post with hugo new, hugo spawns an error when using this theme:

ERROR 2017/05/17 10:23:44 Unable to find archetypes directory for theme "hugo-octopress" at "/home/simonszu/blog/themes/hugo-octopress/archetypes"

Although, the post file is created. However, this error is ugly.

@parsiya

This comment has been minimized.

Copy link
Owner

commented May 21, 2017

Does your website have an archetypes directory? I do not see the error in my own setup because I have one.

Alternatively I can add a default archetype to the theme. Some themes have a default one and some don't.

@parsiya parsiya self-assigned this May 21, 2017
@simonszu

This comment has been minimized.

Copy link
Contributor Author

commented May 26, 2017

Yes, my website has an archetype directory. I think it will be enough if you add an empty directory, since hugo does not really check the contents (which is the reason the post file is still created for now)

@parsiya parsiya closed this in 6dc45f7 Jul 8, 2017
@mikewillems

This comment has been minimized.

Copy link

commented Jun 9, 2018

Hi, so this error doesn't appear at all solved. I experienced the same thing, and as the OP says, Hugo creates the post, but my repo already contains an archetypes/ directory with a default.md in it, and the error still shows up. Judging by the fact that the error message is plainly wrong (claims it's unable to find an archetypes directory at the location of an archetypes directory), I'd say this should be considered a genuine bug.

@parsiya

This comment has been minimized.

Copy link
Owner

commented Jun 22, 2018

OK I need to look into this in a few weeks. Currently travelling.

@parsiya parsiya reopened this Jun 22, 2018
@mikewillems

This comment has been minimized.

Copy link

commented Jun 22, 2018

@parsiya

This comment has been minimized.

Copy link
Owner

commented Jul 11, 2018

Thanks for waiting. I just created a new site. Tried with and without default.md in the site (kept the archetype in theme) and did not get any errors.

Can you deploy a barebones example site with the error to Github so I can figure out why you are getting the error?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.