Skip to content
Permalink
Browse files

objection: 1.8.3 bump

  • Loading branch information
blshkv committed Dec 2, 2019
1 parent b592b3e commit 47fbfda57ef5e280252d27c49b4c8301b74f901f
Showing with 47 additions and 0 deletions.
  1. +1 −0 dev-util/objection/Manifest
  2. +46 −0 dev-util/objection/objection-1.8.3.ebuild
@@ -1,3 +1,4 @@
DIST objection-1.7.0-node_modules.tar.gz 15801482 BLAKE2B 55008cdde77c06488148f9e093271c729ae9a17779aa9bc0163789294fea92460e22c4e5ea02c5b7a702030fa85e450bcad67d03b5249cd4fbb47fa1668992df SHA512 97b3fadc85b92183cd0057ca0b6108b0f210a8d0ea729cdba9fda5e343629a4390daac9b06da3a4fca27504a70882ee00b819d7b9df04d64202c1d25e0615f88
DIST objection-1.7.5.tar.gz 1669556 BLAKE2B bc0981091411ee4837106bf6380dce99e278706d678f80a099730a2110df1951728916ca1202de215e75944986dde3105e01c4f54919610d25a8b0423ff37a38 SHA512 2b7f1623f0564c289ac6e1f5748fc31b2c3950b30fe425e10880b8f4c7df73d46af0fb8f9f8d931d2130fa8d6544a3e0e3ce00b1f0fb16e3f9dee05283a76f65
DIST objection-1.8.2.tar.gz 1673037 BLAKE2B 299f088f4e56ea3b8bbe7561d5939b492573d3becf76626bffae52e3194d1df0eaa397be437c4f61a8fbf86302eaffe27533ccaf32cc3be0da69350de1d1e3de SHA512 fff9f2df21895871db40abe0dd1d03b51da33eec5378ebe9cf2687b1554ecf83da6828718d7a94ffc8ae40357c209e71b90c62e2bc0bed1270d49d730c26f2b2
DIST objection-1.8.3.tar.gz 1680243 BLAKE2B fda478557a53359a6505de47a1832b9a9c2c3d7c93521112ad2a6c07b8ed77a87485db790966d37208dc5b162fe57020f61372df46309146e55de160657f0ab8 SHA512 7338edf7ac08abe040c467b187262b6cda59220ab175ea4e334d6c51a9e70fa59031373c136798dd727e893dc5bf5481950fa2350e4eacee076eea587f8b54ac
@@ -0,0 +1,46 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_6 )
inherit distutils-r1

DESCRIPTION="Runtime mobile exploration"
HOMEPAGE="https://github.com/sensepost/objection"
SRC_URI="https://github.com/sensepost/objection/archive/${PV}.tar.gz -> ${P}.tar.gz
https://dev.pentoo.ch/~blshkv/distfiles/objection-1.7.0-node_modules.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="dev-util/frida-tools[${PYTHON_USEDEP}]
dev-python/frida-python[${PYTHON_USEDEP}]
>=dev-python/prompt_toolkit-2.0.8[${PYTHON_USEDEP}] <dev-python/prompt_toolkit-3.0.0[${PYTHON_USEDEP}]
dev-python/click[${PYTHON_USEDEP}]
dev-python/tabulate[${PYTHON_USEDEP}]
dev-python/delegator[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/flask[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
>=dev-python/litecli-1.1.0[${PYTHON_USEDEP}]
net-libs/nodejs[npm]"

DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"

src_prepare(){
rm -r tests
mv "${WORKDIR}/node_modules" "${S}/agent/" || die "unable to move node_modules"
eapply_user
}

python_compile() {
addpredict /etc/npm
emake frida-agent
# cd agent
# npm run build || die "npm build failed"
distutils-r1_python_compile
}

0 comments on commit 47fbfda

Please sign in to comment.
You can’t perform that action at this time.