Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Email reports contain translation key instead of the translations #3466

Closed
anonymous-piwik-user opened this Issue · 3 comments

2 participants

@anonymous-piwik-user

I used the internal reporting PDF for a week or so then I upgraded to 1.9. the daily reports ever after have been incorectly labeled. all reports show i18n keys in stead of the right label.

I had a look in the bug tracker and I found some "similar" issue, but at the time the bug was dismissed as "not a bug". I removed the whole content of tmp(to be more precise I moved tmp out of the way and created a new empty tmp).

I will see tonight if the problem has been fixed.

if I downloaded the report the labels were correct, but in the emails they were wrong. if the (not a) problem persist, I will carry on this ticket, otherwise feel free to close it.

in the mean time I was wondering if the upgrade script could not take care of cleaning up cache too ;-)...

@mattab
Owner

I reproduced the bug locally, and could send an email report with subject "General_Report Hello world - CoreHome_PeriodWeek CoreHome_LongWeekFormat"

not so cool!

@anonymous-piwik-user

Sorry to be the bad guy adding to it, but I confirm cache had nothing to do with it.
I noticed you raised priority and set an urgent milestone.
Let me know if there is anything I can do to help.

@mattab
Owner

(In [7286]) Fixes #3466

  • Now including Translate.php in the correct order ensuring that scheduled repotrs generated via a Tracker request, make use of translations.
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.