Skip to content
Permalink
Browse files

Make Apache2::request optional and add a dependency for PLack to test…

…Environment
  • Loading branch information...
martink committed Jul 13, 2012
1 parent 544a62d commit 476ddbd307d920904118e248565d0088d1d7e7f1
Showing with 6 additions and 3 deletions.
  1. +6 −3 sbin/testEnvironment.pl
@@ -115,7 +115,8 @@ BEGIN
checkModule("POE", 1.005 );
checkModule("POE::Component::IKC::Server", 0.2001 );
checkModule("POE::Component::Client::HTTP", 0.88 );
checkModule("Apache2::Request", 2.08 );
# In plebgui the mod_perl modules are optional
checkModule("Apache2::Request", 2.08, 2 );
checkModule("URI::Escape", "3.29" );
checkModule("POSIX" );
checkModule("List::Util" );
@@ -162,6 +163,8 @@ BEGIN
checkModule('Data::ICal', '0.16' );
checkModule('common::sense', '3.2' );
checkModule('Geo::Coder::Googlev3', '0.07' );
# Plack is required for plebgui
checkModule('Plack' );

failAndExit("Required modules are missing, running no more checks.") if $missingModule;

@@ -412,9 +415,9 @@ sub isIn {
#----------------------------------------
sub isRootRequirementMet {
if (getOs() eq "Linuxish") {
return ($< == 0);
return ($< == 0);
} else {
return 1;
return 1;
}
}

0 comments on commit 476ddbd

Please sign in to comment.
You can’t perform that action at this time.