PostCSS plugin to insert 3D hack before will-change property
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.editorconfig
.gitignore
.npmignore
.travis.yml
CHANGELOG.md
LICENSE
README.md
index.js
index.test.js
package.json
yarn.lock

README.md

PostCSS Will Change Build Status

PostCSS plugin to insert 3D hack before will-change property.

This plugin uses backface-visibility to force the browser to create a new layer, without overriding existing backface-visibility properties. This 3D CSS hack is commonly done with transform: translateZ(0), but backface-visibility is used here to avoid overriding the more popular transform property.

These hacks are required for browsers that do not support will-change.

Use this plugin only before Autoprefixer. It will add vendor prefixes to backface-visibility.

.foo {
    will-change: transform;
}
.foo {
    backface-visibility: hidden;
    will-change: transform;
}

Usage

postcss([ require('postcss-will-change') ])

See PostCSS docs for examples for your environment.