Join GitHub today
GitHub is home to over 28 million developers working together to host and review code, manage projects, and build software together.Sign up
Require at least MySQL version 5.6.5 #9
The reason for this requirement is that the current codebase requires
The background to this patch is that I noticed there were a few test failures on CPAN Testers and the error that kept cropping up was:
And after a bit of searching I found out that this was a restriction in MySQL which had been fixed in version 5.6.5. Hence, I thought one probably needs a guard in the test suite to make sure that a compatible version of MySQL or MariaDB is available before proceeding further. I've also updated the documentation to note that one requires at least version 5.6.5 of MySQL for the software to work. I know that the docs say that the code had been tested with version 5.5, however my guess is that some change in the past caused the code to no longer be compatible with the older version.
Anyway, have a look and see what you think. If anything needs to be updated or whatever, just let me know and I'll fix and resubmit.
Looks good to me. If someone later wants to come and fix it to work with older MySQLs, they're welcome (but it seems like that'll be a bit difficult, unless we keep some parallel migrations for different MySQL versions or something...)
I fixed the conflict and merged on the command-line, so closing.
Dunno if this helps much, but here's the script I used to check my theory that MySQL 5.5 was causing problems. Debian Jessie has MySQL 5.5 as its standard installation of MySQL, however also provides MariaDB 10.0.x, so it's a good test bed to check the differences. Anyway, perhaps this can be of some use, if only conceptually.