New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ValueError: A 0.7-series setuptools cannot be installed with distribute [But we're on 20.7 now] #543

Closed
adowds opened this Issue Apr 12, 2016 · 3 comments

Comments

Projects
None yet
4 participants
@adowds

adowds commented Apr 12, 2016

When running buildouts bootstrap.py, setuptools generates the error below. This version is 20.7. It looks as if a regex meant to screen for version 0.7 is triggering an error for version 20.7? This is breaking all builds, please help.

ValueError: A 0.7-series setuptools cannot be installed with distribute. Found one at /tmp/tmpIFxckv/setuptools-20.7.0-py2.7.egg
Traceback (most recent call last):
File "bootstrap.py", line 172, in
"Failed to execute command:\n%s" % repr(cmd)[1:-1])
Exception: Failed to execute command:
'/var/lib/jenkins/jobs//job1/workspace/bin/python', '-c', 'from setuptools.command.easy_install import main; main()', '-mZqNxd', '/tmp/tmpIFxckv', 'zc.buildout==2.5.1'

@kzw

This comment has been minimized.

kzw commented Apr 15, 2016

Confirmed. We have to hack up gevent-psycopg2 to not use distribute_setuptools and had to upgrade pycassa. gevent-psycopg2 is unmaintained and we happen to be using it in production:(.

Can we release quickly 20.8.0 just to avoid this problem for the community? And also have a safeguard to never release any version that will have '0.7' in the version string?

@jaraco

This comment has been minimized.

Member

jaraco commented Apr 15, 2016

oh, that's terrible! Yes.

@boegel

This comment has been minimized.

boegel commented Jun 8, 2016

So, wait, let me get this right... This problem was fixed by simply bumping the setuptools version from 20.7.0 to 20.8.0, and pretending this will never be hit again?

I understand you can't fix all setuptools versions out there that have this hard check on '0.7' in the version string, but at least you can put something in place to make sure you don't reintroduce this issue later?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment