Skip to content
Permalink
Browse files
Tweaked deb scripts so we can build pacakges on ubuntu feisty
git-svn-id: http://svn.osgeo.org/qgis/trunk/qgis@7186 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
timlinux committed Sep 11, 2007
1 parent 1b601a8 commit 02378f78131e9d4567e2e350a09b7aaa49e533bb
Showing with 8 additions and 5 deletions.
  1. +1 −1 debian/control
  2. +1 −1 debian/libqgis1.substvars
  3. +1 −1 debian/qgis-plugin-grass.substvars
  4. +1 −1 debian/qgis.substvars
  5. +4 −1 debian/rules
@@ -43,7 +43,7 @@ Description: QGIS Geographic Information System - shared library

Package: libqgis1-dev
Architecture: any
Depends: qgis (= ${Source-Version}), libgdal1-dev , libpq-dev | postgresql-dev, libgeos-dev (>= 2.0.1-1), grass-dev, libsqlite3-dev, libgsl0-dev, proj, libexpat1-dev, libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0), libqt4-qt3support (>=4.2.0), libqt4-sql (>=4.2.0), python-qt4 (>=4.2.0), python-qt4-dev (>=4.2.0), qt4-designer (>=4.2.0)
Depends: qgis (= ${Source-Version}), libgdal1-dev , libpq-dev | postgresql-dev, libgeos-dev (>= 2.0.1-1), grass-dev, libsqlite3-dev, libgsl0-dev, proj, libexpat1-dev, libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0), libqt4-qt3support (>=4.2.0), libqt4-sql (>=4.2.0), python-qt4 (>=4.0.0), python-qt4-dev (>=4.0.0), qt4-designer (>=4.2.0)
Provides: libqgis-dev
Conflicts: libqgis-dev, qgis-dev
Replaces: qgis-dev
@@ -1 +1 @@
shlibs:Depends=libc6 (>= 2.3.6-6), libgcc1 (>= 1:4.1.1-12), libgdal1-1.3.2, libgeos2c2a (>= 2.2.3), libqt4-core (>= 4.2.1), libqt4-gui (>= 4.2.1), libqt4-qt3support (>= 4.2.1), libsqlite3-0 (>= 3.3.8), libstdc++6 (>= 4.1.1-12), proj (>= 4.4.1-1)
shlibs:Depends=libc6 (>= 2.5-0ubuntu1), libgcc1 (>= 1:4.1.2), libgdal1-1.3.2, libgeos2c2a (>= 2.2.3), libqt4-core (>= 4.3.0), libqt4-gui (>= 4.3.0), libqt4-qt3support (>= 4.3.0), libsqlite3-0 (>= 3.3.13), libstdc++6 (>= 4.1.2), proj (>= 4.4.1-1)
@@ -1 +1 @@
shlibs:Depends=libc6 (>= 2.3.6-6), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2), libgcc1 (>= 1:4.1.1-12), libgdal1-1.3.2, libgeos2c2a (>= 2.2.3), libice6 (>= 1:1.0.0), libpng12-0 (>= 1.2.13-4), libqt4-core (>= 4.2.1), libqt4-gui (>= 4.2.1), libqt4-qt3support (>= 4.2.1), libsm6, libsqlite3-0 (>= 3.3.8), libstdc++6 (>= 4.1.1-12), libx11-6, libxcursor1 (>> 1.1.2), libxext6, libxinerama1, libxrandr2, libxrender1, proj (>= 4.4.1-1), zlib1g (>= 1:1.2.1)
shlibs:Depends=libc6 (>= 2.5-0ubuntu1), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2), libgcc1 (>= 1:4.1.2), libgdal1-1.3.2, libgeos2c2a (>= 2.2.3), libice6 (>= 1:1.0.0), libpng12-0 (>= 1.2.13-4), libqt4-core (>= 4.3.0), libqt4-gui (>= 4.3.0), libqt4-qt3support (>= 4.3.0), libsm6, libsqlite3-0 (>= 3.3.13), libstdc++6 (>= 4.1.2), libx11-6, libxcursor1 (>> 1.1.2), libxext6, libxi6, libxinerama1, libxrandr2 (>= 2:1.2.0), libxrender1, proj (>= 4.4.1-1), zlib1g (>= 1:1.2.1)
@@ -1 +1 @@
shlibs:Depends=libc6 (>= 2.3.6-6), libexpat1 (>= 1.95.8), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2), libgcc1 (>= 1:4.1.1-12), libgdal1-1.3.2, libgeos2c2a (>= 2.2.3), libgsl0 (>= 1.4), libice6 (>= 1:1.0.0), libpng12-0 (>= 1.2.13-4), libpq4 (>= 8.1.4), libqt4-core (>= 4.2.1), libqt4-gui (>= 4.2.1), libqt4-qt3support (>= 4.2.1), libsm6, libsqlite3-0 (>= 3.3.8), libstdc++6 (>= 4.1.1-12), libx11-6, libxcursor1 (>> 1.1.2), libxext6, libxinerama1, libxrandr2, libxrender1, proj (>= 4.4.1-1), python2.4 (>= 2.3.90), zlib1g (>= 1:1.2.1)
shlibs:Depends=libc6 (>= 2.5-0ubuntu1), libexpat1 (>= 1.95.8), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.2), libgcc1 (>= 1:4.1.2), libgdal1-1.3.2, libgeos2c2a (>= 2.2.3), libgsl0 (>= 1.4), libice6 (>= 1:1.0.0), libpng12-0 (>= 1.2.13-4), libpq5, libqt4-core (>= 4.3.0), libqt4-gui (>= 4.3.0), libqt4-qt3support (>= 4.3.0), libsm6, libsqlite3-0 (>= 3.3.13), libstdc++6 (>= 4.1.2), libx11-6, libxcursor1 (>> 1.1.2), libxext6, libxi6, libxinerama1, libxrandr2 (>= 2:1.2.0), libxrender1, proj (>= 4.4.1-1), python2.5 (>= 2.5), zlib1g (>= 1:1.2.1)
@@ -29,7 +29,10 @@ CMakeCache.txt: CMakeLists.txt
dh_testdir
# Add here commands to configure the package.
uudecode -o $(CURDIR)/src/plugins/georeferencer/pencil.png $(CURDIR)/debian/pencil.uu
cmake -D CMAKE_INSTALL_PREFIX=/usr -D GDAL_INCLUDE_DIR=/usr/include/gdal .
cmake -D CMAKE_INSTALL_PREFIX=/usr \
-D GDAL_INCLUDE_DIR=/usr/include/gdal \
-D GDAL_LIBRARY=/usr/lib/libgdal1.3.2.so \
.

build: patch build-stamp

0 comments on commit 02378f7

Please sign in to comment.