Skip to content
Permalink
Browse files

Update Mac release scripts.

git-svn-id: http://svn.osgeo.org/qgis/trunk@6133 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
telwertowski
telwertowski committed Nov 27, 2006
1 parent c00b2b7 commit ac147d1a61d753fac49d790c45ab82de70f065c7
@@ -5,7 +5,7 @@
\margl1440\margr1440\vieww11100\viewh8700\viewkind0
\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\tx5040\tx5760\tx6480\tx7200\tx7920\tx8640\qc

\f0\b\fs24 \cf0 QGIS 0.8.0 Preview 2 Release Notes for Macintosh
\f0\b\fs24 \cf0 QGIS 0.8.0 Preview 3 Release Notes for Macintosh
\f1\b0 \
\pard\tx720\tx1440\tx2160\tx2880\tx3600\tx4320\tx5040\tx5760\tx6480\tx7200\tx7920\tx8640\ql\qnatural
\cf0 \
@@ -55,8 +55,8 @@ GeoTIFF 1.2.3 (libgeotiff.1.2.3.dylib)\
JasPer 1.701.0.GEO (libjasper-1.701.1.0.0.dylib)\
Expat 2.0.0 (libexpat.1.5.0.dylib)\
GSL 1.8 (libgsl.0.9.0.dylib, libgslcblas.0.0.0.dylib)\
PostgreSQL 8.1.4 (libpq.4.1.dylib) This client can also access a version 7 server.\
GRASS 6.0.2 (libgrass_*.6.0.2.dylib) The plugin will also work with GRASS 6.1.x.\
PostgreSQL 8.1.5 (libpq.4.1.dylib) This client can also access a version 7 server.\
GRASS 6.2.0 (libgrass_*.6.2.0.dylib)\
\
\
\
@@ -118,7 +118,7 @@ One method is to launch QGIS from the GRASS command-line prompt:\
\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f2 \cf0 /Applications/qgis-0.8.0pre2/qgis.app/Contents/MacOS/qgis\
\f2 \cf0 /Applications/qgis-0.8.0pre3/qgis.app/Contents/MacOS/qgis\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f1 \cf0 \
@@ -135,7 +135,7 @@ To do this for GRASS 6.0.x, open the file\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

\f2 \cf0 "&Ext" all options $tmenu \{\
\{command "Open QGIS" \{\} "Open QGIS (Quantum GIS) with Grass support enabled" \{\} -command \{ exec $env(GRASS_HTML_BROWSER) "/Applications/qgis-0.8.0pre2/qgis.app" & \} \}\
\{command "Open QGIS" \{\} "Open QGIS (Quantum GIS) with Grass support enabled" \{\} -command \{ exec $env(GRASS_HTML_BROWSER) "/Applications/qgis-0.8.0pre3/qgis.app" & \} \}\
\}\
\pard\tx560\tx1120\tx1680\tx2240\tx2800\tx3360\tx3920\tx4480\tx5040\tx5600\tx6160\tx6720\ql\qnatural

@@ -13,12 +13,16 @@ QLIBNAMES="composer core gui legend"
# Declare libqgis_* relative to bundle and update qgis app client
for NAME in $QLIBNAMES
do
install_name_tool -id @executable_path/lib/libqgis_$NAME.0.0.1.dylib \
$BUILDPREFIX/lib/libqgis_$NAME.0.0.1.dylib
install_name_tool -id @executable_path/lib/libqgis_$NAME.1.0.0.dylib \
$BUILDPREFIX/lib/libqgis_$NAME.1.0.0.dylib

install_name_tool -change $BUILDPREFIX/lib/libqgis_$NAME.0.dylib \
@executable_path/lib/libqgis_$NAME.0.dylib \
install_name_tool -change $BUILDPREFIX/lib/libqgis_$NAME.1.dylib \
@executable_path/lib/libqgis_$NAME.1.dylib \
$BUILDPREFIX/qgis

install_name_tool -change $BUILDPREFIX/lib/libqgis_$NAME.1.dylib \
@executable_path/lib/libqgis_$NAME.1.dylib \
$BUILDPREFIX/bin/msexport.app/Contents/MacOS/msexport
done

# Declare libqgis_libqgis_raster relative to bundle and update qgis app client
@@ -30,6 +34,10 @@ install_name_tool -change $BUILDPREFIX/lib/libqgis_raster.0.dylib \
@executable_path/lib/libqgis_raster.0.dylib \
$BUILDPREFIX/qgis

install_name_tool -change $BUILDPREFIX/lib/libqgis_raster.0.dylib \
@executable_path/lib/libqgis_raster.0.dylib \
$BUILDPREFIX/bin/msexport.app/Contents/MacOS/msexport

# Declare libqgsprojectionselector relative to bundle and update qgis app client
install_name_tool -id @executable_path/lib/qgis/libqgsprojectionselector.dylib \
$BUILDPREFIX/lib/qgis/libqgsprojectionselector.dylib
@@ -38,13 +46,17 @@ install_name_tool -change $BUILDPREFIX/lib/qgis/libqgsprojectionselector.dylib \
@executable_path/lib/qgis/libqgsprojectionselector.dylib \
$BUILDPREFIX/qgis

install_name_tool -change $BUILDPREFIX/lib/qgis/libqgsprojectionselector.dylib \
@executable_path/lib/qgis/libqgsprojectionselector.dylib \
$BUILDPREFIX/bin/msexport.app/Contents/MacOS/msexport

# Update libqgis_gui client of libqgis_*
for LIB in libqgis_composer.0.dylib libqgis_core.0.dylib libqgis_legend.0.dylib \
for LIB in libqgis_composer.1.dylib libqgis_core.1.dylib libqgis_legend.1.dylib \
libqgis_raster.0.dylib qgis/libqgsprojectionselector.dylib
do
install_name_tool -change $BUILDPREFIX/lib/$LIB \
@executable_path/lib/$LIB \
$BUILDPREFIX/lib/libqgis_gui.0.0.1.dylib
$BUILDPREFIX/lib/libqgis_gui.1.0.0.dylib
done

# Update plugin and lib clients of libqgis_* and libqgsprojectionselector
@@ -59,35 +71,40 @@ for PLUGIN in \
qgis/grassprovider.so \
qgis/gridmakerplugin.so \
qgis/libScaleBarplugin.so \
qgis/libwfsprovider.so \
qgis/northarrowplugin.so \
qgis/ogrprovider.so \
qgis/pggeoprocessingplugin.so \
qgis/postgresprovider.so \
qgis/spitplugin.so \
qgis/wfsplugin.so \
qgis/wmsprovider.so \
qgis/libqgsprojectionselector.dylib \
libqgisgrass.0.0.1.dylib
libqgisgrass.1.0.0.dylib
do
for NAME in $QLIBNAMES raster
for NAME in $QLIBNAMES
do
install_name_tool -change $BUILDPREFIX/lib/libqgis_$NAME.0.dylib \
@executable_path/lib/libqgis_$NAME.0.dylib \
install_name_tool -change $BUILDPREFIX/lib/libqgis_$NAME.1.dylib \
@executable_path/lib/libqgis_$NAME.1.dylib \
$BUILDPREFIX/lib/$PLUGIN
done
install_name_tool -change $BUILDPREFIX/lib/libqgis_raster.0.dylib \
@executable_path/lib/libqgis_raster.0.dylib \
$BUILDPREFIX/lib/$PLUGIN
install_name_tool -change $BUILDPREFIX/lib/qgis/libqgsprojectionselector.dylib \
@executable_path/lib/qgis/libqgsprojectionselector.dylib \
$BUILDPREFIX/lib/$PLUGIN
done

# Declare libqgisgrass relative to bundle
install_name_tool -id @executable_path/lib/libqgisgrass.0.0.1.dylib \
$BUILDPREFIX/lib/libqgisgrass.0.0.1.dylib
install_name_tool -id @executable_path/lib/libqgisgrass.1.0.0.dylib \
$BUILDPREFIX/lib/libqgisgrass.1.0.0.dylib

# Update plugin clients of libqgisgrass
for PLUGIN in qgis/grassplugin.so qgis/grassprovider.so
do
install_name_tool -change $BUILDPREFIX/lib/libqgisgrass.0.dylib \
@executable_path/lib/libqgisgrass.0.dylib \
install_name_tool -change $BUILDPREFIX/lib/libqgisgrass.1.dylib \
@executable_path/lib/libqgisgrass.1.dylib \
$BUILDPREFIX/lib/$PLUGIN
done

@@ -13,12 +13,12 @@ otool -L $PREFIX/bin/qgis-config
otool -L $PREFIX/bin/spit

otool -L $PREFIX/lib/libmsexport.0.0.0.dylib
otool -L $PREFIX/lib/libqgis_composer.0.0.1.dylib
otool -L $PREFIX/lib/libqgis_core.0.0.1.dylib
otool -L $PREFIX/lib/libqgis_gui.0.0.1.dylib
otool -L $PREFIX/lib/libqgis_legend.0.0.1.dylib
otool -L $PREFIX/lib/libqgis_composer.1.0.0.dylib
otool -L $PREFIX/lib/libqgis_core.1.0.0.dylib
otool -L $PREFIX/lib/libqgis_gui.1.0.0.dylib
otool -L $PREFIX/lib/libqgis_legend.1.0.0.dylib
otool -L $PREFIX/lib/libqgis_raster.0.0.0.dylib
otool -L $PREFIX/lib/libqgisgrass.0.0.1.dylib
otool -L $PREFIX/lib/libqgisgrass.1.0.0.dylib
otool -L $PREFIX/lib/qgis/copyrightlabelplugin.so
otool -L $PREFIX/lib/qgis/delimitedtextplugin.so
otool -L $PREFIX/lib/qgis/delimitedtextprovider.so
@@ -29,11 +29,13 @@ otool -L $PREFIX/lib/qgis/grassplugin.so
otool -L $PREFIX/lib/qgis/grassprovider.so
otool -L $PREFIX/lib/qgis/gridmakerplugin.so
otool -L $PREFIX/lib/qgis/libScaleBarplugin.so
otool -L $PREFIX/lib/qgis/libwfsprovider.so
otool -L $PREFIX/lib/qgis/northarrowplugin.so
otool -L $PREFIX/lib/qgis/ogrprovider.so
otool -L $PREFIX/lib/qgis/pggeoprocessingplugin.so
otool -L $PREFIX/lib/qgis/postgresprovider.so
otool -L $PREFIX/lib/qgis/spitplugin.so
otool -L $PREFIX/lib/qgis/wfsplugin.so
otool -L $PREFIX/lib/qgis/wmsprovider.so
otool -L $PREFIX/lib/qgis/libqgsprojectionselector.dylib
#otool -L $PREFIX/lib/qgis/libopenmodellerplugin.so
@@ -77,5 +79,5 @@ otool -L $PREFIX/lib/libpq.4.1.dylib

for LIBGRASS in datetime dbmibase dbmiclient dgl dig2 form gis gmath gproj I linkm rtree shape vask vect
do
otool -L $PREFIX/lib/grass/libgrass_$LIBGRASS.6.0.2.dylib
otool -L $PREFIX/lib/grass/libgrass_$LIBGRASS.6.2.0.dylib
done
@@ -7,7 +7,7 @@ PREFIX=qgis.app/Contents/MacOS
# Edit version when any library is upgraded
LNKGDAL=libgdal.1.dylib
LNKPROJ=libproj.0.dylib
GRASSVER=6.0.2
GRASSVER=6.2.0
GRASSLIB=/usr/local/grass-$GRASSVER/lib

cd $PREFIX/lib
@@ -105,10 +105,10 @@ for FILE in \
bin/msexport.app/Contents/MacOS/msexport \
bin/spit \
lib/libmsexport.0.0.0.dylib \
lib/libqgis_core.0.0.1.dylib \
lib/libqgis_gui.0.0.1.dylib \
lib/libqgis_core.1.0.0.dylib \
lib/libqgis_gui.1.0.0.dylib \
lib/libqgis_raster.0.0.0.dylib \
lib/libqgisgrass.0.0.1.dylib \
lib/libqgisgrass.1.0.0.dylib \
lib/qgis/copyrightlabelplugin.so \
lib/qgis/delimitedtextplugin.so \
lib/qgis/delimitedtextprovider.so \
@@ -119,11 +119,13 @@ for FILE in \
lib/qgis/grassprovider.so \
lib/qgis/gridmakerplugin.so \
lib/qgis/libScaleBarplugin.so \
lib/qgis/libwfsprovider.so \
lib/qgis/northarrowplugin.so \
lib/qgis/ogrprovider.so \
lib/qgis/pggeoprocessingplugin.so \
lib/qgis/postgresprovider.so \
lib/qgis/spitplugin.so \
lib/qgis/wfsplugin.so \
lib/qgis/wmsprovider.so \
lib/qgis/libqgsprojectionselector.dylib
#bin/omgui \
@@ -41,7 +41,7 @@ LNKEXPAT=libexpat.1.dylib
#LNKOPENMODELLER=libopenmodeller.0.dylib
LIBPQ=libpq.4.1.dylib
LNKPQ=libpq.4.dylib
GRASSLIB=/usr/local/grass-6.0.2/lib
GRASSLIB=/usr/local/grass-6.2.0/lib

# Copy supporting libraries to application bundle
cd $PREFIX/lib
@@ -202,9 +202,9 @@ install_name_tool -change /usr/local/lib/$LNKJASPER @executable_path/lib/$LNKJAS
install_name_tool -change /usr/local/pgsql/lib/$LNKPQ @executable_path/lib/$LNKPQ $PREFIX/qgis

# Update library paths to supporting libraries
install_name_tool -change /usr/local/lib/$LNKGEOS @executable_path/lib/$LNKGEOS $PREFIX/lib/libqgis_core.0.0.1.dylib
install_name_tool -change /usr/local/lib/$LNKSQLITE3 @executable_path/lib/$LNKSQLITE3 $PREFIX/lib/libqgis_core.0.0.1.dylib
for LIB in _core.0.0.1 _gui.0.0.1 _raster.0.0.0 grass.0.0.1
install_name_tool -change /usr/local/lib/$LNKGEOS @executable_path/lib/$LNKGEOS $PREFIX/lib/libqgis_core.1.0.0.dylib
install_name_tool -change /usr/local/lib/$LNKSQLITE3 @executable_path/lib/$LNKSQLITE3 $PREFIX/lib/libqgis_core.1.0.0.dylib
for LIB in _core.1.0.0 _gui.1.0.0 _raster.0.0.0 grass.1.0.0
do
install_name_tool -change /usr/local/lib/$LNKGDAL @executable_path/lib/$LNKGDAL $PREFIX/lib/libqgis$LIB.dylib
install_name_tool -change /usr/local/lib/$LNKGEOS @executable_path/lib/$LNKGEOS $PREFIX/lib/libqgis$LIB.dylib
@@ -230,11 +230,13 @@ for PLUGIN in \
grassprovider.so \
gridmakerplugin.so \
libScaleBarplugin.so \
libwfsprovider.so \
northarrowplugin.so \
ogrprovider.so \
pggeoprocessingplugin.so \
postgresprovider.so \
spitplugin.so \
wfsplugin.so \
wmsprovider.so \
libqgsprojectionselector.dylib
#libopenmodellerplugin.so
@@ -270,7 +272,7 @@ install_name_tool -change /usr/local/lib/$LNKEXPAT @executable_path/lib/$LNKEXPA

# Update GRASS plugins paths to GRASS libraries
for PLUGIN in \
libqgisgrass.0.0.1.dylib \
libqgisgrass.1.0.0.dylib \
qgis/grassplugin.so
do
for LIB in datetime dbmibase dbmiclient dgl dig2 form gis gproj linkm rtree shape vect
@@ -298,6 +300,17 @@ install_name_tool -change /usr/local/lib/$LNKPNG @executable_path/lib/$LNKPNG $H
ln -sf $PREFIXBACKTRACK/lib $HELPPREFIX/lib

# Update msexort application paths to supporting libraries
install_name_tool -change /usr/local/lib/$LNKGDAL @executable_path/lib/$LNKGDAL $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKGEOS @executable_path/lib/$LNKGEOS $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKSQLITE3 @executable_path/lib/$LNKSQLITE3 $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKXERCESC @executable_path/lib/$LNKXERCESC $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKGIF @executable_path/lib/$LNKGIF $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKJPEG @executable_path/lib/$LNKJPEG $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKPNG @executable_path/lib/$LNKPNG $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKTIFF @executable_path/lib/$LNKTIFF $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKGEOTIFF @executable_path/lib/$LNKGEOTIFF $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/lib/$LNKJASPER @executable_path/lib/$LNKJASPER $MSEXPORTPREFIX/msexport
install_name_tool -change /usr/local/pgsql/lib/$LNKPQ @executable_path/lib/$LNKPQ $MSEXPORTPREFIX/msexport
ln -sf $PREFIXBACKTRACK/lib $MSEXPORTPREFIX/lib

# Update omgui application paths to supporting libraries
@@ -12,12 +12,12 @@ strip -x $PREFIX/bin/qgis-config
strip -x $PREFIX/bin/spit

strip -x $PREFIX/lib/libmsexport.0.0.0.dylib
strip -x $PREFIX/lib/libqgis_composer.0.0.1.dylib
strip -x $PREFIX/lib/libqgis_core.0.0.1.dylib
strip -x $PREFIX/lib/libqgis_gui.0.0.1.dylib
strip -x $PREFIX/lib/libqgis_legend.0.0.1.dylib
strip -x $PREFIX/lib/libqgis_composer.1.0.0.dylib
strip -x $PREFIX/lib/libqgis_core.1.0.0.dylib
strip -x $PREFIX/lib/libqgis_gui.1.0.0.dylib
strip -x $PREFIX/lib/libqgis_legend.1.0.0.dylib
strip -x $PREFIX/lib/libqgis_raster.0.0.0.dylib
strip -x $PREFIX/lib/libqgisgrass.0.0.1.dylib
strip -x $PREFIX/lib/libqgisgrass.1.0.0.dylib
strip -x $PREFIX/lib/qgis/copyrightlabelplugin.so
strip -x $PREFIX/lib/qgis/delimitedtextplugin.so
strip -x $PREFIX/lib/qgis/delimitedtextprovider.so
@@ -28,11 +28,13 @@ strip -x $PREFIX/lib/qgis/grassplugin.so
strip -x $PREFIX/lib/qgis/grassprovider.so
strip -x $PREFIX/lib/qgis/gridmakerplugin.so
strip -x $PREFIX/lib/qgis/libScaleBarplugin.so
strip -x $PREFIX/lib/qgis/libwfsprovider.so
strip -x $PREFIX/lib/qgis/northarrowplugin.so
strip -x $PREFIX/lib/qgis/ogrprovider.so
strip -x $PREFIX/lib/qgis/pggeoprocessingplugin.so
strip -x $PREFIX/lib/qgis/postgresprovider.so
strip -x $PREFIX/lib/qgis/spitplugin.so
strip -x $PREFIX/lib/qgis/wfsplugin.so
strip -x $PREFIX/lib/qgis/wmsprovider.so
strip -x $PREFIX/lib/qgis/libqgsprojectionselector.dylib
#strip -x $PREFIX/lib/qgis/libopenmodellerplugin.so
@@ -76,7 +78,7 @@ strip -x $PREFIX/lib/libpq.4.1.dylib

for LIBGRASS in datetime dbmibase dbmiclient dgl dig2 form gis gmath gproj I linkm rtree shape vask vect
do
strip -x $PREFIX/lib/grass/libgrass_$LIBGRASS.6.0.2.dylib
strip -x $PREFIX/lib/grass/libgrass_$LIBGRASS.6.2.0.dylib
done

# Delete unneeded files in application bundle
@@ -190,6 +190,7 @@
<string>ru</string>
<string>sk</string>
<string>sv</string>
<string>vi</string>
<string>zh_CN</string>
</array>
</dict>

0 comments on commit ac147d1

Please sign in to comment.
You can’t perform that action at this time.