Skip to content
Permalink
Browse files

[travis] Modernize Mac OSX dependencies

  • Loading branch information
m-kuhn committed Jul 11, 2016
1 parent c895ba3 commit d06859a88d883711d8f7673bb4bf65ac3edf595e
Showing with 6 additions and 4 deletions.
  1. +0 −2 .travis.yml
  2. +5 −2 ci/travis/osx/before_install.sh
  3. +1 −0 ci/travis/osx/install.sh
@@ -1,7 +1,5 @@
matrix:
fast_finish: true
allow_failures:
- os: osx
include:
# QT4 based build with Python 2.7 // using container based builds and prebuild binary dependencies in osgeo4travis
- os: linux
@@ -13,10 +13,12 @@
# #
###########################################################################

# Remove default gdal provided by travis (we will replace it with gdal 2)
brew remove gdal || true

brew tap osgeo/osgeo4mac
brew update
brew install osgeo/osgeo4mac/qgis-28 --without-postgis --without-postgresql --without-grass --without-gpsbabel --only-dependencies
brew install qca
brew install osgeo/osgeo4mac/qgis-214 --without-postgresql --only-dependencies
brew install spawn-fcgi
brew install lighttpd
brew install poppler
@@ -31,6 +33,7 @@ brew ln libffi --force

mkdir -p ${HOME}/Library/Python/2.7/lib/python/site-packages
echo 'import site; site.addsitedir("/usr/local/lib/python2.7/site-packages")' >> ${HOME}/Library/Python/2.7/lib/python/site-packages/homebrew.pth
echo 'import site; site.addsitedir("/usr/local/opt/gdal-20/lib/python2.7/site-packages")' >> ${HOME}/Library/Python/2.7/lib/python/site-packages/gdal2.pth

# Needed for Processing
pip install psycopg2 numpy nose2 pyyaml mock future
@@ -30,5 +30,6 @@ cmake \
-DWITH_PYSPATIALITE=ON \
-DQWT_INCLUDE_DIR=/usr/local/opt/qwt/lib/qwt.framework/Headers/ \
-DQWT_LIBRARY=/usr/local/opt/qwt/lib/qwt.framework/qwt \
-DGDAL_CONFIG=/usr/local/opt/gdal-20/bin/gdal-config \
-DCMAKE_CXX_FLAGS="-Wno-deprecated-declarations" \
..

0 comments on commit d06859a

Please sign in to comment.
You can’t perform that action at this time.