Skip to content
Permalink
Browse files
feat: raise minimum version of Node to v14.17 (#248)
Co-authored-by: João Pedro Henrique <joao.pedro.hsd@gmail.com>

BREAKING CHANGE: the minimum required version of node is now v14.17
  • Loading branch information
gr2m committed Sep 17, 2021
1 parent 5d7a717 commit 6eeaeb2c08bfc4ca299bd03973a44a6ea711bef2
Showing with 6 additions and 5 deletions.
  1. +4 −3 .github/workflows/test.yml
  2. +2 −2 package.json
@@ -13,9 +13,8 @@ jobs:
strategy:
matrix:
node-version:
- 10
- 12
- 14
- 14.17
- 16
os:
- ubuntu-latest
- macos-latest
@@ -28,6 +27,8 @@ jobs:
with:
node-version: "${{ matrix.node-version }}"
cache: npm
- name: Ensure dependencies are compatible with the version of node
run: echo 'engine-strict=true' >> .npmrc
- run: npm ci
- run: "npm run test:ci"
test:
@@ -38,7 +38,7 @@
"xo": "0.28.3"
},
"engines": {
"node": ">=10.18"
"node": ">=14.17"
},
"files": [
"lib",
@@ -70,7 +70,7 @@
"all": true
},
"peerDependencies": {
"semantic-release": ">=16.0.0 <18.0.0"
"semantic-release": ">=18.0.0-beta.1"
},
"prettier": {
"printWidth": 120,

0 comments on commit 6eeaeb2

Please sign in to comment.