Skip to content
Permalink
Browse files
feat(node-version): raised the minimum required version to v14.17
BREAKING CHANGE: the minimum required version of node is now v14.17
  • Loading branch information
UziTech committed Sep 20, 2021
1 parent 9105df6 commit 7ab65f8c8d30443d589aedbaa8ac3ea235144aef
Showing with 112 additions and 109 deletions.
  1. +4 −3 .github/workflows/test.yml
  2. +105 −103 package-lock.json
  3. +3 −3 package.json
@@ -13,9 +13,8 @@ jobs:
strategy:
matrix:
node-version:
- 10
- 12
- 14
- '14.17'
- 16
os:
- ubuntu-latest
- macos-latest
@@ -31,6 +30,8 @@ jobs:
node-version: "${{ matrix.node-version }}"
cache: npm
- run: npm ci
- name: Ensure dependencies are compatible with the version of node
run: npx ls-engines
- run: "npm run test:ci"
test:
runs-on: ubuntu-latest

Some generated files are not rendered by default. Learn more.

@@ -33,13 +33,13 @@
"get-stream": "6.0.1",
"git-log-parser": "1.2.0",
"nyc": "15.1.0",
"semantic-release": "17.4.7",
"semantic-release": "18.0.0",
"sinon": "11.1.2",
"tempy": "1.0.1",
"xo": "0.28.3"
},
"engines": {
"node": ">=10.18"
"node": ">=14.17"
},
"files": [
"lib",
@@ -71,7 +71,7 @@
"all": true
},
"peerDependencies": {
"semantic-release": ">=16.0.0 <18.0.0"
"semantic-release": ">=18.0.0"
},
"prettier": {
"printWidth": 120,

0 comments on commit 7ab65f8

Please sign in to comment.