Permalink
Browse files

introducing rspec; cleaning up the less stuff and try to use the "off…

…icial" less gem which will work only with znix
  • Loading branch information...
1 parent 54f3375 commit 9bd596e0e492f143bd941ff780a240f0258f6fc7 @mkuhl mkuhl committed Sep 24, 2011
View
@@ -4,3 +4,4 @@ log/*.log
tmp/
.sass-cache/
.idea/
+vendor/plugins/Rename/
View
1 .rspec
@@ -0,0 +1 @@
+--colour
View
@@ -11,15 +11,18 @@ gem 'rails', '3.1.0'
group :assets do
gem 'sass-rails', " ~> 3.1.0"
gem 'coffee-rails', "~> 3.1.0"
+ gem "less"
gem 'uglifier'
end
gem 'jquery-rails'
-gem 'tilt', :git => 'git://github.com/thisduck/tilt.git'
-gem 'less-js'
-gem 'devise'
+#gem 'tilt', :git => 'git://github.com/thisduck/tilt.git'
+gem 'tilt'
+#gem 'less-js'
+# gem 'execjs'
+gem 'devise'
group :development do
View
@@ -1,161 +1,160 @@
-GIT
- remote: git://github.com/thisduck/tilt.git
- revision: a61592ebf52f48a5e94d1faadb227002013daccb
- specs:
- tilt (1.3.3)
-
-GEM
- remote: http://rubygems.org/
- specs:
- actionmailer (3.1.0)
- actionpack (= 3.1.0)
- mail (~> 2.3.0)
- actionpack (3.1.0)
- activemodel (= 3.1.0)
- activesupport (= 3.1.0)
- builder (~> 3.0.0)
- erubis (~> 2.7.0)
- i18n (~> 0.6)
- rack (~> 1.3.2)
- rack-cache (~> 1.0.3)
- rack-mount (~> 0.8.2)
- rack-test (~> 0.6.1)
- sprockets (~> 2.0.0)
- activemodel (3.1.0)
- activesupport (= 3.1.0)
- bcrypt-ruby (~> 3.0.0)
- builder (~> 3.0.0)
- i18n (~> 0.6)
- activerecord (3.1.0)
- activemodel (= 3.1.0)
- activesupport (= 3.1.0)
- arel (~> 2.2.1)
- tzinfo (~> 0.3.29)
- activeresource (3.1.0)
- activemodel (= 3.1.0)
- activesupport (= 3.1.0)
- activesupport (3.1.0)
- multi_json (~> 1.0)
- ansi (1.3.0)
- arel (2.2.1)
- bcrypt-ruby (3.0.0-x86-mingw32)
- builder (3.0.0)
- coffee-rails (3.1.0)
- coffee-script (>= 2.2.0)
- railties (~> 3.1.0.rc1)
- coffee-script (2.2.0)
- coffee-script-source
- execjs
- coffee-script-source (1.1.2)
- devise (1.4.4)
- bcrypt-ruby (~> 3.0)
- orm_adapter (~> 0.0.3)
- warden (~> 1.0.3)
- diff-lcs (1.1.3)
- erubis (2.7.0)
- execjs (1.2.4)
- multi_json (~> 1.0)
- factory_girl (2.1.0)
- factory_girl_rails (1.2.0)
- factory_girl (~> 2.1.0)
- railties (>= 3.0.0)
- faker (1.0.0)
- i18n (~> 0.4)
- hike (1.2.1)
- i18n (0.6.0)
- jquery-rails (1.0.13)
- railties (~> 3.0)
- thor (~> 0.14)
- less-js (0.1.1)
- execjs
- less-js-source
- less-js-source (1.1.3)
- mail (2.3.0)
- i18n (>= 0.4.0)
- mime-types (~> 1.16)
- treetop (~> 1.4.8)
- mime-types (1.16)
- multi_json (1.0.3)
- orm_adapter (0.0.5)
- pg (0.11.0-x86-mingw32)
- polyglot (0.3.2)
- rack (1.3.2)
- rack-cache (1.0.3)
- rack (>= 0.4)
- rack-mount (0.8.3)
- rack (>= 1.0.0)
- rack-ssl (1.3.2)
- rack
- rack-test (0.6.1)
- rack (>= 1.0)
- rails (3.1.0)
- actionmailer (= 3.1.0)
- actionpack (= 3.1.0)
- activerecord (= 3.1.0)
- activeresource (= 3.1.0)
- activesupport (= 3.1.0)
- bundler (~> 1.0)
- railties (= 3.1.0)
- railties (3.1.0)
- actionpack (= 3.1.0)
- activesupport (= 3.1.0)
- rack-ssl (~> 1.3.2)
- rake (>= 0.8.7)
- rdoc (~> 3.4)
- thor (~> 0.14.6)
- rake (0.9.2)
- rdoc (3.9.4)
- rspec (2.6.0)
- rspec-core (~> 2.6.0)
- rspec-expectations (~> 2.6.0)
- rspec-mocks (~> 2.6.0)
- rspec-core (2.6.4)
- rspec-expectations (2.6.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.6.0)
- rspec-rails (2.6.1)
- actionpack (~> 3.0)
- activesupport (~> 3.0)
- railties (~> 3.0)
- rspec (~> 2.6.0)
- sass (3.1.7)
- sass-rails (3.1.0)
- actionpack (~> 3.1.0)
- railties (~> 3.1.0)
- sass (>= 3.1.4)
- sprockets (2.0.0)
- hike (~> 1.2)
- rack (~> 1.0)
- tilt (!= 1.3.0, ~> 1.1)
- sqlite3 (1.3.4-x86-mingw32)
- thor (0.14.6)
- treetop (1.4.10)
- polyglot
- polyglot (>= 0.3.1)
- turn (0.8.2)
- ansi (>= 1.2.2)
- tzinfo (0.3.29)
- uglifier (1.0.3)
- execjs (>= 0.3.0)
- multi_json (>= 1.0.2)
- warden (1.0.5)
- rack (>= 1.0)
-
-PLATFORMS
- x86-mingw32
-
-DEPENDENCIES
- coffee-rails (~> 3.1.0)
- devise
- factory_girl_rails
- faker
- jquery-rails
- less-js
- pg
- rails (= 3.1.0)
- rspec-rails (= 2.6.1)
- sass-rails (~> 3.1.0)
- sqlite3
- tilt!
- turn
- uglifier
+GEM
+ remote: http://rubygems.org/
+ specs:
+ actionmailer (3.1.0)
+ actionpack (= 3.1.0)
+ mail (~> 2.3.0)
+ actionpack (3.1.0)
+ activemodel (= 3.1.0)
+ activesupport (= 3.1.0)
+ builder (~> 3.0.0)
+ erubis (~> 2.7.0)
+ i18n (~> 0.6)
+ rack (~> 1.3.2)
+ rack-cache (~> 1.0.3)
+ rack-mount (~> 0.8.2)
+ rack-test (~> 0.6.1)
+ sprockets (~> 2.0.0)
+ activemodel (3.1.0)
+ activesupport (= 3.1.0)
+ bcrypt-ruby (~> 3.0.0)
+ builder (~> 3.0.0)
+ i18n (~> 0.6)
+ activerecord (3.1.0)
+ activemodel (= 3.1.0)
+ activesupport (= 3.1.0)
+ arel (~> 2.2.1)
+ tzinfo (~> 0.3.29)
+ activeresource (3.1.0)
+ activemodel (= 3.1.0)
+ activesupport (= 3.1.0)
+ activesupport (3.1.0)
+ multi_json (~> 1.0)
+ ansi (1.3.0)
+ arel (2.2.1)
+ bcrypt-ruby (3.0.1)
+ builder (3.0.0)
+ coffee-rails (3.1.1)
+ coffee-script (>= 2.2.0)
+ railties (~> 3.1.0)
+ coffee-script (2.2.0)
+ coffee-script-source
+ execjs
+ coffee-script-source (1.1.2)
+ devise (1.4.7)
+ bcrypt-ruby (~> 3.0)
+ orm_adapter (~> 0.0.3)
+ warden (~> 1.0.3)
+ diff-lcs (1.1.3)
+ erubis (2.7.0)
+ execjs (1.2.8)
+ multi_json (~> 1.0)
+ factory_girl (2.1.2)
+ activesupport
+ factory_girl_rails (1.2.0)
+ factory_girl (~> 2.1.0)
+ railties (>= 3.0.0)
+ faker (1.0.0)
+ i18n (~> 0.4)
+ hike (1.2.1)
+ i18n (0.6.0)
+ jquery-rails (1.0.14)
+ railties (~> 3.0)
+ thor (~> 0.14)
+ less (2.0.7)
+ therubyracer (~> 0.9.2)
+ libv8 (3.3.10.2)
+ mail (2.3.0)
+ i18n (>= 0.4.0)
+ mime-types (~> 1.16)
+ treetop (~> 1.4.8)
+ mime-types (1.16)
+ multi_json (1.0.3)
+ orm_adapter (0.0.5)
+ pg (0.11.0)
+ polyglot (0.3.2)
+ rack (1.3.3)
+ rack-cache (1.0.3)
+ rack (>= 0.4)
+ rack-mount (0.8.3)
+ rack (>= 1.0.0)
+ rack-ssl (1.3.2)
+ rack
+ rack-test (0.6.1)
+ rack (>= 1.0)
+ rails (3.1.0)
+ actionmailer (= 3.1.0)
+ actionpack (= 3.1.0)
+ activerecord (= 3.1.0)
+ activeresource (= 3.1.0)
+ activesupport (= 3.1.0)
+ bundler (~> 1.0)
+ railties (= 3.1.0)
+ railties (3.1.0)
+ actionpack (= 3.1.0)
+ activesupport (= 3.1.0)
+ rack-ssl (~> 1.3.2)
+ rake (>= 0.8.7)
+ rdoc (~> 3.4)
+ thor (~> 0.14.6)
+ rake (0.9.2)
+ rdoc (3.9.4)
+ rspec (2.6.0)
+ rspec-core (~> 2.6.0)
+ rspec-expectations (~> 2.6.0)
+ rspec-mocks (~> 2.6.0)
+ rspec-core (2.6.4)
+ rspec-expectations (2.6.0)
+ diff-lcs (~> 1.1.2)
+ rspec-mocks (2.6.0)
+ rspec-rails (2.6.1)
+ actionpack (~> 3.0)
+ activesupport (~> 3.0)
+ railties (~> 3.0)
+ rspec (~> 2.6.0)
+ sass (3.1.7)
+ sass-rails (3.1.2)
+ actionpack (~> 3.1.0)
+ railties (~> 3.1.0)
+ sass (>= 3.1.4)
+ sprockets (~> 2.0.0)
+ tilt (~> 1.3.2)
+ sprockets (2.0.0)
+ hike (~> 1.2)
+ rack (~> 1.0)
+ tilt (!= 1.3.0, ~> 1.1)
+ sqlite3 (1.3.4)
+ therubyracer (0.9.4)
+ libv8 (~> 3.3.10)
+ thor (0.14.6)
+ tilt (1.3.3)
+ treetop (1.4.10)
+ polyglot
+ polyglot (>= 0.3.1)
+ turn (0.8.2)
+ ansi (>= 1.2.2)
+ tzinfo (0.3.29)
+ uglifier (1.0.3)
+ execjs (>= 0.3.0)
+ multi_json (>= 1.0.2)
+ warden (1.0.5)
+ rack (>= 1.0)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ coffee-rails (~> 3.1.0)
+ devise
+ factory_girl_rails
+ faker
+ jquery-rails
+ less
+ pg
+ rails (= 3.1.0)
+ rspec-rails (= 2.6.1)
+ sass-rails (~> 3.1.0)
+ sqlite3
+ tilt
+ turn
+ uglifier
@@ -0,0 +1,3 @@
+# Place all the behaviors and hooks related to the matching controller here.
+# All this logic will automatically be available in application.js.
+# You can use CoffeeScript in this file: http://jashkenas.github.com/coffee-script/
@@ -1,15 +0,0 @@
-/* CSS Reset */
-<%= File.read "#{Rails.root}/app/assets/stylesheets/bootstrap/reset.less" %>
-
-/* Core */
-<%= File.read "#{Rails.root}/app/assets/stylesheets/bootstrap/variables.less" %>
-<%= File.read "#{Rails.root}/app/assets/stylesheets/bootstrap/mixins.less" %>
-
-// Grid system and page structure
-<%= File.read "#{Rails.root}/app/assets/stylesheets/bootstrap/scaffolding.less" %>
-
-/* Styled patterns and elements */
-<%= File.read "#{Rails.root}/app/assets/stylesheets/bootstrap/type.less" %>
-<%= File.read "#{Rails.root}/app/assets/stylesheets/bootstrap/forms.less" %>
-<%= File.read "#{Rails.root}/app/assets/stylesheets/bootstrap/tables.less" %>
-<%= File.read "#{Rails.root}/app/assets/stylesheets/bootstrap/patterns.less" %>
Oops, something went wrong.

0 comments on commit 9bd596e

Please sign in to comment.