New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Geocode Nominatim (this.opions undefined (line 469)) #180

Closed
malde11 opened this Issue Oct 18, 2017 · 2 comments

Comments

Projects
None yet
3 participants
@malde11

malde11 commented Oct 18, 2017

I changed the version of the leaflet-search plugin and get this message in the console:
TypeError: this.options is undefined (line 469)

Autocomplete is not working. Same error on your example site.

I see you are working on it the past days. Hope you can fix it.

Great work, thanks.

@jieter

This comment has been minimized.

Show comment
Hide comment
@jieter

jieter Oct 24, 2017

Just downgraded to 2.3.5 to make this work again.

@stefanocudini It would also be really helpful to have tags for each version and a changelog.

jieter commented Oct 24, 2017

Just downgraded to 2.3.5 to make this work again.

@stefanocudini It would also be really helpful to have tags for each version and a changelog.

@malde11

This comment has been minimized.

Show comment
Hide comment
@malde11

malde11 Oct 25, 2017

Sorry, I am a beginner and really new to this git thing. I have downloaded the newest .zip-file from this repository. I wanted to get rid of this error message in the console:

Deprecated include of L.Mixin.Events: this property will be removed in future releases, please inherit from L.Evented instead.

Now, I updated(leaflet 1.2.0 and the newest zip-file from leaflet-search, I guess it is the master branch) everything and got this message in the first post.

Is the newest zip-file the 2.3.6 version?
Do I need git or npm to get the 2.3.5 version? I found under releases only the 2.3.0 version.
I have installed git now, but do not know the right command, to get this 2.3.5 version. Is it possible with git or do I need npm?

Thanks for the help. 😅

Edit:
OK, I did it, but maby a complicated way.
I have searched in the the commits in the leaflet-search.min.js after 2.3.5 here:
https://github.com/stefanocudini/leaflet-search/tree/2a5dff993bcb8a55c8191730201225d9983b1735

malde11 commented Oct 25, 2017

Sorry, I am a beginner and really new to this git thing. I have downloaded the newest .zip-file from this repository. I wanted to get rid of this error message in the console:

Deprecated include of L.Mixin.Events: this property will be removed in future releases, please inherit from L.Evented instead.

Now, I updated(leaflet 1.2.0 and the newest zip-file from leaflet-search, I guess it is the master branch) everything and got this message in the first post.

Is the newest zip-file the 2.3.6 version?
Do I need git or npm to get the 2.3.5 version? I found under releases only the 2.3.0 version.
I have installed git now, but do not know the right command, to get this 2.3.5 version. Is it possible with git or do I need npm?

Thanks for the help. 😅

Edit:
OK, I did it, but maby a complicated way.
I have searched in the the commits in the leaflet-search.min.js after 2.3.5 here:
https://github.com/stefanocudini/leaflet-search/tree/2a5dff993bcb8a55c8191730201225d9983b1735

tger pushed a commit to tger/leaflet-search that referenced this issue Oct 31, 2017

stefanocudini added a commit that referenced this issue Nov 13, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment