Skip to content
Electrum; Bitcoin thin client
Python Shell NSIS HTML Makefile PHP
Branch: master
Clone or download
Pull request Compare This branch is 41 commits ahead, 4611 commits behind spesmilo:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
contrib Fix automerge issues Jan 11, 2017
gui
icons Fix icon Dec 30, 2016
lib
plugins Fix automerge issues Jan 11, 2017
pubkeys Add my own public key. Jun 26, 2015
scripts BTC to STRAT Dec 28, 2016
.gitignore High Res ico Dec 30, 2016
.travis.yml travis: use Tox for test automation Jul 2, 2015
AUTHORS BTC to STRAT Dec 28, 2016
Info.plist BTC to STRAT Dec 28, 2016
LICENCE Relicensing Feb 24, 2016
MANIFEST.in BTC to STRAT Dec 28, 2016
README.rst Change to stratisproject Github Jan 9, 2017
RELEASE-NOTES Update version Jan 26, 2018
app.fil updates for i18n translations Aug 1, 2016
electrum-env
electrum-stratis Disable JSON-RPC in GUI Jan 22, 2018
electrum-stratis.conf.sample Fix fee Dec 30, 2016
electrum-stratis.desktop BTC to STRAT Dec 28, 2016
electrum.icns Change icns file to Stratis Dec 30, 2016
icons.qrc BTC to STRAT Dec 28, 2016
setup-release.py BTC to STRAT Dec 28, 2016
setup.py BTC to STRAT Dec 28, 2016
tox.ini travis: use Tox for test automation Jul 2, 2015

README.rst

Electrum-Stratis - Lightweight Stratis client

Licence: MIT Licence
Original Author: Thomas Voegtlin
Port Maintainer: dev0tion
Language: Python
Homepage: https://www.stratisplatform.com

Getting started

Electrum is a pure python application. However, if you want to use the Qt interface, then you need to install the Qt dependencies:

sudo apt-get install python-qt4

If you downloaded the official package (tar.gz), then you can run Electrum from its root directory, without installing it on your system; all the python dependencies are included in the 'packages' directory. To run Electrum from its root directory, just do:

./electrum-stratis

You can also install Electrum on your system, by running this command:

python setup.py install

This will download and install the Python dependencies used by Electrum, instead of using the 'packages' directory.

If you cloned the git repository, then you need to compile extra files before you can run Electrum. Read the next section, "Development Version".

Development version

Check out the code from Github:

git clone git://github.com/stratisproject/electrum-stratis
cd electrum-stratis

Run install (this should install dependencies):

python setup.py install

Compile the icons file for Qt:

sudo apt-get install pyqt4-dev-tools
pyrcc4 icons.qrc -o gui/qt/icons_rc.py

Compile the protobuf description file:

sudo apt-get install protobuf-compiler
protoc --proto_path=lib/ --python_out=lib/ lib/paymentrequest.proto

Create translations (optional):

sudo apt-get install python-pycurl gettext
./contrib/make_locale

Creating Binaries

In order to create binaries, you must create the 'packages' directory:

./contrib/make_packages

This directory contains the python dependencies used by Electrum.

Mac OS X

# On MacPorts installs:
sudo python setup-release.py py2app

# On Homebrew installs:
ARCHFLAGS="-arch i386 -arch x86_64" sudo python setup-release.py py2app --includes sip

sudo hdiutil create -fs HFS+ -volname "Electrum-Stratis" -srcfolder dist/Electrum-Stratis.app dist/electrum-stratis-VERSION-macosx.dmg

Windows

See contrib/build-wine/README file.

Android

See gui/kivy/Readme.txt file.

You can’t perform that action at this time.