simple css to make select2 widgets fit in with bootstrap
CSS HTML JavaScript Ruby Makefile
Latest commit 1855431 May 27, 2016 @t0m typo

README.md

Select2 Bootstrap CSS

Simple CSS to make Select2 widgets fit in with Bootstrap.


  • This branch (master) contains the legacy version for Bootstrap 2.
  • The legacy bootstrap 3 branch is here: bootstrap3 branch.*

The LESS file is located at lib/select2-bootstrap.less, and the SCSS file is located at lib/select2-bootstrap.scss.

Tests are included to verify that LESS and SCSS compile down to the target CSS. To run the tests, you'll need to install node.js, Less, and SASS. Then you can run:

npm install && bower install
npm test

Notable Changes

Versions prior to 1.2.0 included a default width for select2 containers. Applying the class "input-default" to your select will line the select2 container up with a default bootstrap text input.

Compass

This library can also be used as a Compass plugin.

Gemfile:

gem 'select2-bootstrap-css'

compass.rb:

require 'select2-bootstrap-css'

Your scss file:

@import 'select2-bootstrap';

Demos

http://t0m.github.io/select2-bootstrap-css/