Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Remove dependencies on uglifier and coffee-rails #33

Merged
merged 1 commit into from

2 participants

@thomsbg

Remove uglifier and coffee-rails from the 3.1 gemfile, and modify spec_helper.rb to respect a BUNDLE_GEMFILE set on the command line. Fixes thoughtbot/shoulda#190.

Blake Thomson Remove uglifier and coffee-rails from the 3.1 gemfile, and modify spe…
…c_helper.rb to respect a BUNDLE_GEMFILE set on the command line.
7660061
@thomsbg thomsbg referenced this pull request in thoughtbot/shoulda
Closed

Running shoulda-matchers specs fails in non-OSX environments #190

@mike-burns mike-burns merged commit 7660061 into from
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Nov 2, 2011
  1. Remove uglifier and coffee-rails from the 3.1 gemfile, and modify spe…

    Blake Thomson authored
    …c_helper.rb to respect a BUNDLE_GEMFILE set on the command line.
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 5 deletions.
  1. +0 −2  Appraisals
  2. +0 −2  gemfiles/3.1.gemfile
  3. +1 −1  spec/spec_helper.rb
View
2  Appraisals
@@ -4,8 +4,6 @@ end
appraise "3.1" do
gem "rails", "3.1.0"
- gem 'uglifier'
gem 'jquery-rails'
- gem 'coffee-rails'
gem 'sass-rails'
end
View
2  gemfiles/3.1.gemfile
@@ -10,9 +10,7 @@ gem "jdbc-sqlite3", :platform=>:jruby
gem "jruby-openssl", :platform=>:jruby
gem "shoulda-context", "~> 1.0.0.beta1"
gem "rails", "3.1.0"
-gem "uglifier"
gem "jquery-rails"
-gem "coffee-rails"
gem "sass-rails"
gemspec :path=>"../"
View
2  spec/spec_helper.rb
@@ -4,7 +4,7 @@
`rails new #{TESTAPP_ROOT}`
ENV['RAILS_ENV'] = 'test'
-ENV['BUNDLE_GEMFILE'] = TESTAPP_ROOT + '/Gemfile'
+ENV['BUNDLE_GEMFILE'] ||= TESTAPP_ROOT + '/Gemfile'
require "#{TESTAPP_ROOT}/config/environment"
require 'rspec'
Something went wrong with that request. Please try again.