Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Backwards Compatibility for $GLOBALS['quick_cache'] is missing #691

Closed
Kedakai opened this issue Feb 26, 2016 · 7 comments
Closed

Backwards Compatibility for $GLOBALS['quick_cache'] is missing #691

Kedakai opened this issue Feb 26, 2016 · 7 comments
Labels
bug
Milestone

Comments

@Kedakai
Copy link

@Kedakai Kedakai commented Feb 26, 2016

Good evening everyone,
i have a very annoying Issue.
Environment:
Wordpress Site, that has used Zencache before (Which worked fine!).

One of my friends told me this evening that changes made in the Plugins:
"Pretty simple progress meter" or
"tablepress" are not visible for not logged-in users.

I knew immediately that this was a Comet Cache Issue, but i thought about other points before, because of the fact, that Zencache worked perfectly.
I've checked the File permissions, checked if Comet Cache is on the newest Version.

If i try to change a site or a post, Comet Cache clears the cache just fine and the contect if visible for everyone.

Any Idea how to fix this?

Faithfully,
Alexander

@raamdev
Copy link
Contributor

@raamdev raamdev commented Feb 27, 2016

@Kedakai If you reinstall ZenCache, does the problem go away?

The Comet Cache codebase is exactly the same as the ZenCache codebase--the only thing we changed was the name of the plugin. So if it was working fine with ZenCache, it should work just fine with Comet Cache. If you can reinstall ZenCache and verify that it actually does work with ZenCache but not with Comet Cache, I'll see if I can take a closer look.

One other thing comes to mind: Do you have any custom code in place (an MU-Plugin, perhaps) that is using the ZenCache API? The current version of Comet Cache is supposed to include full backwards compatibility for ZenCache, but that compatibility is currently broken in Comet Cache v160223.1. We'll be doing a maintenance release this weekend to fix the backwards compatibility with ZenCache.

@Kedakai
Copy link
Author

@Kedakai Kedakai commented Feb 27, 2016

With Zencache the changes in tablepress worked fine.
Comet Cache does not recognize this changes, i think.

I have recorded the Issue so i can prove what i'm saying.
https://www.youtube.com/watch?v=_iH43m9AOcc (Available soon in 1080P60FPS)

I have no Costum Plugins installed and i haven't modified a Plugin ever.

@raamdev
Copy link
Contributor

@raamdev raamdev commented Feb 27, 2016

@Kedakai Thank you very much for the video. I just watched it and I see the problem you are demonstrating. I will look into this issue a bit more and update here when I have more info.

@raamdev raamdev added bug and removed needs feedback labels Feb 27, 2016
@raamdev raamdev added this to the Next Release milestone Feb 27, 2016
@raamdev
Copy link
Contributor

@raamdev raamdev commented Feb 27, 2016

@Kedakai I have confirmed the bug. The issue is that TablePress is using $GLOBALS['quick_cache']->clear_cache() to integrate with our caching plugin. That's the old API call (it should now be comet_cache::clear(); see Is there an API call that clears the cache?). ZenCache had backwards compatibility for Quick Cache, but Comet Cache dropped support for Quick Cache backwards compatibility.

We're going to add Quick Cache backwards compatibility back into Comet Cache so that plugins like TablePress continue to work as expected. This fix will go out with the next release, later today. :-)

Thanks so much for reporting this!

@Kedakai
Copy link
Author

@Kedakai Kedakai commented Feb 27, 2016

@raamdev, great!
Thanks for the great support :-)

raamdev added a commit to wpsharks/comet-cache-pro that referenced this issue Feb 27, 2016
@raamdev raamdev changed the title Comet Cache does not clear for some Plugins Backwards Compatibility for $GLOBALS['quick_cache'] is missing Feb 27, 2016
@raamdev
Copy link
Contributor

@raamdev raamdev commented Feb 27, 2016

Next Release Changelog:

  • Bug Fix: Fixed a Quick Cache Backwards Compatibility bug that was preventing calls to $GLOBALS['quick_cache'] from working properly with Comet Cache. Props to @Kedakai for reporting. See Issue #691.
@raamdev raamdev closed this Feb 27, 2016
@raamdev
Copy link
Contributor

@raamdev raamdev commented Feb 27, 2016

Comet Cache v160227 has been released and includes changes from this GitHub Issue. See the v160227 announcement for further details.


This issue will now be locked to further updates. If you have something to add related to this GitHub Issue, please open a new GitHub Issue and reference this one (#691).

@wpsharks wpsharks locked and limited conversation to collaborators Feb 27, 2016
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants