Skip to content

Package Repositories

Defaultldentity edited this page Dec 24, 2018 · 20 revisions

Package Repositories

This page contains information about community and distribution maintained packages and repositories. Here you will find more detailed instructions on how to install a distribution package.

Please note that anyone can create a repository and add the necessary information to this wiki page. The PulseEffects developer(s) cannot guarantee the security of these repositories, or that they are still maintained.

If you are having any issues that you suspect are specific to your installation method, please contact the respective package maintainer, as listed on this page.

Arch Linux

To install pulseeffects on Arch, run:

sudo pacman -S pulseeffects

Debian / Ubuntu

Ubuntu 18.04 and Newer, Debian 9 and Newer

Packages provided by mikhailnov.

To install PulseEffects on Ubuntu >= 18.04 (18.04, 18.10 etc.) and Mint >= 19 do:

sudo add-apt-repository ppa:mikhailnov/pulseeffects -y
sudo apt update
sudo apt install pulseeffects pulseaudio --install-recommends

PulseAudio >=12 is recommended (see issue #99). It will be installed from this PPA. Ubuntu's patches are ported from Ubuntu 18.10 to 18.04.

Restart the user session or reboot after this, because PulseAudio will be upgraded, and it may cause problems if you don't restart.

These package should, but probably won't be compatible with recent releases of Debian/Deepin and other Debian-based distributions. To try installing PulseEffects on Debian/Deepin:

echo "deb http://ppa.launchpad.net/mikhailnov/pulseeffects/ubuntu bionic main" | sudo tee /etc/apt/sources.list.d/mikhailnov-ubuntu-pulseeffects-bionic.list
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys FE3AE55CF74041EAA3F0AD10D5B19A73A8ECB754 
echo -e "Package: * \nPin: release o=LP-PPA-mikhailnov-pulseeffects \nPin-Priority: 1" | sudo tee /etc/apt/preferences.d/mikhailnov-ubuntu-pulseeffects-ppa
sudo apt update
sudo apt install pulseeffects

Gentoo

Packages provided by prometheanfire.

emerge media-sound/pulseeffects

Flatpak

Provided by Flathub and maintained by AsavarTzeth.

flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
flatpak install flathub com.github.wwmm.pulseeffects

The Flatpak manifest can be found here: https://github.com/flathub/com.github.wwmm.pulseeffects

Mageia

PulseEffects will be available in the Mageia repositories from Mageia 7 onwards and may be installed directly from the Mageia Control Center.

You can’t perform that action at this time.