Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Embedded attached images are not displayed when viewing a diagram from another page via the "display" macro #121

Closed
slauriere opened this issue Feb 28, 2020 · 0 comments · Fixed by #147
Assignees
Milestone

Comments

@slauriere
Copy link

@slauriere slauriere commented Feb 28, 2020

Steps to reproduce

  • Create a diagram
  • Add an attachment image to the diagram wiki page via the "+" button
  • Embed that image in the diagram
  • In another wiki page, display the diagram via {{display reference=""/}}

Actual versus expected results

In its own page, the diagram shows up as expected, with the included image, while in the other page, the image is not displayed, possibly because it seems the reference to the image is relative to the diagram page itself only.

NB: when doing "File > Import from device", the image is embedded in the XML itself, so there is no issue. The "+" button seems to provide various actions with different implementations than other similar buttons (i.e. "insert a link" action), so one option could consist in not displaying that button at all, or conversely not the others.

@oanalavinia oanalavinia self-assigned this May 18, 2020
oanalavinia added a commit to oanalavinia/application-diagram that referenced this issue May 20, 2020
…m another page via the "display" macro xwikisas#121

* added the documentReference to the AttachmentReference that's on image link
oanalavinia added a commit to oanalavinia/application-diagram that referenced this issue May 25, 2020
…m another page via the "display" macro xwikisas#121

* used diagramReference as parent when loading the image
oanalavinia added a commit to oanalavinia/application-diagram that referenced this issue May 25, 2020
…m another page via the "display" macro xwikisas#121

* forgot to delete xwiki-meta dependency
oanalavinia added a commit to oanalavinia/application-diagram that referenced this issue May 26, 2020
…m another page via the "display" macro xwikisas#121


* code style

Co-authored-by: Marius Dumitru Florea <marius@xwiki.com>
oanalavinia added a commit that referenced this issue May 27, 2020
…m another page via the "display" macro #121

* used diagramReference as parent when loading the image
@oanalavinia oanalavinia added this to the 1.13.2 milestone May 27, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants