Skip to content

Releases: DSpace/DSpace

DSpace 7.4 (Backend / REST API Only)

06 Oct 19:49
Compare
Choose a tag to compare

DSpace 7.4 Release of the Backend / REST API only. The 7.4 release provides new features & bug fixes to the 7.x platform. See Release Notes for all details.

This DSpace Backend does not have a user friendly interface. Therefore, we highly recommend installing the DSpace 7 Frontend dspace-7.4 release to use with this Backend. Please note that the Frontend and Backend do not need to be installed on the same machine. (Note: it is also possible to run this Backend "headless" if you only want to use the DSpace REST API)

Download links for the Backend are available below (see Assets). You may alternatively choose to checkout the code via GitHub, using the dspace-7.4 tag.

Additional Information on the 7.4 release:

DSpace 6.4

29 Jul 13:16
Compare
Choose a tag to compare

⚠️ Support for DSpace 6 will be ending on July 1, 2023.  See Support for DSpace 5 and 6 is ending in 2023. If you are installing DSpace for the first time, we recommend installing DSpace 7


The DSpace 6.4 bug-fix / security fix release. This release provides security and bug fixes to the 6.x platform. For more information see: https://wiki.lyrasis.org/display/DSDOC6x/Release+Notes

DSpace 6.4 provides security fixes to the JSPUI and XMLUI. We highly recommend ALL users of DSpace 6.x upgrade to 6.4

For a list of all specific fixes, please refer to the Release Notes

Documentation is available at https://wiki.lyrasis.org/display/DSDOC6x/

NOTE: If you plan to customize or modify DSpace, we recommend downloading the Source Release (-src-release.*). The smaller Release (-release.*) downloads only include the precompiled binaries.

DSpace 5.11

29 Jul 13:14
Compare
Choose a tag to compare

⚠️ Support for DSpace 5 will be ending on January 1, 2023.  See Support for DSpace 5 and 6 is ending in 2023. If you are installing DSpace for the first time, we recommend installing DSpace 7


The DSpace 5.11 bug-fix / security fix release. This release provides security and bug fixes to the 5.x platform. For more information see: https://wiki.lyrasis.org/display/DSDOC5x/Release+Notes

DSpace 5.11 provides security fixes to the JSPUI and XMLUI. We highly recommend ALL users of DSpace 5.x upgrade to 5.11

For a list of all specific fixes, please refer to the Release Notes

Documentation is available at https://wiki.lyrasis.org/display/DSDOC5x/

NOTE: If you plan to customize or modify DSpace, we recommend downloading the Source Release (-src-release.*). The smaller Release (-release.*) downloads only include the precompiled binaries.

DSpace 7.3 (Backend / REST API Only)

24 Jun 18:40
Compare
Choose a tag to compare

DSpace 7.3 Release of the Backend / REST API only. The 7.3 release provides new features & bug fixes to the 7.x platform. See Release Notes for all details.

This DSpace Backend does not have a user friendly interface. Therefore, we highly recommend installing the DSpace 7 Frontend dspace-7.3 release to use with this Backend. Please note that the Frontend and Backend do not need to be installed on the same machine. (Note: it is also possible to run this Backend "headless" if you only want to use the DSpace REST API)

Download links for the Backend are available below (see Assets). You may alternatively choose to checkout the code via GitHub, using the dspace-7.3 tag.

Additional Information on the 7.3 release:

DSpace 7.2.1 (Backend / REST API Only)

01 Apr 15:36
Compare
Choose a tag to compare

This is an updated version of the 7.2 release which includes a security update for CVE-2022-22965 (Spring4Shell critical vulnerability) and CVE-2022-22950. It is fully compatible with the DSpace 7.2 Frontend dspace-7.2 release.


⚠️ We highly recommend ALL users of DSpace 7.2 upgrade your backend to 7.2.1 (or later) to resolve CVE-2022-22965. If you cannot upgrade immediately or are running 7.1 or 7.0, then you should apply one of the patches or workarounds detailed in #8231


This DSpace Backend does not have a user friendly interface. Therefore, we highly recommend installing the DSpace 7 Frontend dspace-7.2 release to use with this Backend. Please note that the Frontend and Backend do not need to be installed on the same machine. (Note: it is also possible to run this Backend "headless" if you only want to use the DSpace REST API)

Download links for the Backend are available below (see Assets). You may alternatively choose to checkout the code via GitHub, using the dspace-7.2.1 tag.

Additional Information on the 7.2 release:

Full Changelog of 7.2.1: dspace-7.2...dspace-7.2.1

DSpace 7.2 (Backend / REST API Only)

03 Feb 20:07
Compare
Choose a tag to compare

DSpace 7.2 Release of the Backend / REST API only. The 7.2 release provides new features, security & bug fixes to the 7.x platform. See Release Notes for all details.

This DSpace Backend does not have a user friendly interface. Therefore, we highly recommend installing the DSpace 7 Frontend dspace-7.2 release to use with this Backend. Please note that the Frontend and Backend do not need to be installed on the same machine. (Note: it is also possible to run this Backend "headless" if you only want to use the DSpace REST API)

Download links for the Backend are available below (see Assets). You may alternatively choose to checkout the code via GitHub, using the dspace-7.2 tag.

Additional Information on the 7.2 release:

DSpace 7.1.1 (Backend / REST API Only)

13 Dec 19:47
Compare
Choose a tag to compare

This is an updated version of the 7.1 release which includes a security update for CVE-2021-44228 (log4j v2 critical vulnerability). It is fully compatible with the DSpace 7 Frontend dspace-7.1 release.


⚠️ We highly recommend ALL users of DSpace 7.0 or 7.1 upgrade to 7.1.1 (or above) to resolve CVE-2021-44228.

To fully protect your DSpace 7.x site from CVE-2021-44228, three steps are required:

  1. Upgrade your DSpace backend to 7.1.1 (or above) OR manually install #8065, rebuild and redeploy your 7.x backend. Make sure to restart your Tomcat after the update.
  2. Upgrade to Apache Solr v8.11.1 (or above), OR ensure that -Dlog4j2.formatMsgNoLookups=true is specified in your SOLR_OPTS environment variable. For more information, see https://solr.apache.org/security.html#apache-solr-affected-by-apache-log4j-cve-2021-44228
  3. If you use the Handle.Net Registry Support in DSpace 7.x, make sure to restart your Handle Server (after performing step 1), so that it uses the new (secure) version of log4j as well.

This DSpace Backend does not have a user friendly interface. Therefore, we highly recommend installing the DSpace 7 Frontend dspace-7.1 release to use with this Backend. Please note that the Frontend and Backend do not need to be installed on the same machine. (Note: it is also possible to run this Backend "headless" if you only want to use the DSpace REST API)

Download links for the Backend are available below (see Assets). You may alternatively choose to checkout the code via GitHub, using the dspace-7.1.1 tag.

Additional Information on the 7.1 release:

Full Changelog of 7.1.1: dspace-7.1...dspace-7.1.1

DSpace 7.1 (Backend / REST API Only)

28 Oct 21:30
Compare
Choose a tag to compare

⚠️ We highly recommend ALL users of DSpace 7.0 or 7.1 upgrade to 7.1.1 to resolve CVE-2021-44228 (log4j critical vulnerability).

For more details see https://github.com/DSpace/DSpace/releases/tag/dspace-7.1.1


DSpace 7.1 Release of the Backend / REST API only. The 7.1 release provides new features, security & bug fixes to the 7.x platform. See Release Notes for all details.

DSpace 7.1 provides a security fix to the Backend / REST API. We highly recommend ALL users of DSpace 7.0 upgrade to 7.1.

This DSpace Backend does not have a user friendly interface. Therefore, we highly recommend installing the DSpace 7 Frontend dspace-7.1 release to use with this Backend. Please note that the Frontend and Backend do not need to be installed on the same machine. (Note: it is also possible to run this Backend "headless" if you only want to use the DSpace REST API)

Download links for the Backend are available below (see Assets). You may alternatively choose to checkout the code via GitHub, using the dspace-7.1 tag.

Additional Information on the 7.1 release:

DSpace 7.0 (Backend / REST API Only)

29 Jul 20:11
Compare
Choose a tag to compare

DSpace 7.0 Release of the Backend / REST API only.

This DSpace Backend does not have a user friendly interface. Therefore, we highly recommend installing the DSpace 7 Frontend dspace-7.0 release to use with this Backend. Please note that the Frontend and Backend do not need to be installed on the same machine. (Note: it is also possible to run this Backend "headless" if you only want to use the DSpace REST API)

Download links for the Backend are available below (see Assets). You may alternatively choose to checkout the code via GitHub, using the dspace-7.0 tag.

Additional Information on the 7.0 release:

DSpace 7.0 Beta 5 Release (Backend / REST API Only)

15 Apr 22:11
Compare
Choose a tag to compare

DSpace 7.0 Beta 5 Release of the Backend / REST API only.

As a Beta release, this is NOT PRODUCTION READY. Beta 5 is the final Beta release to be use during Testathon. More information is available about the 7.0 final release

This DSpace Backend does not have a user friendly interface. Therefore, we highly recommend installing the DSpace 7 Frontend dspace-7.0-beta5 release to use with this Backend. Please note that the Frontend and Backend do not need to be installed on the same machine.

Additional Information on the 7.0-beta5 release: